Page MenuHome

Unwrap crashes blender
Closed, ResolvedPublic

Description

System Information
win7 64 / quadro 4000

Blender Version
Broken: (example: 2.72b 64 bit official)
Worked: (same crash in 2.67)

Short description of error
Created a curatin aranged in a circle. when trying to unwrap, -blender crashes.

Exact steps for others to reproduce the error
Load blend testfile (see pasteall link).


Enter editmode. select all. hit u for unwrap.
-blender crashes

Maybe a hint:
deleting one loop, will prevent from crashing.
See this file:

cheers, dave

Details

Type
Bug

Event Timeline

dd (buggee) raised the priority of this task from to Needs Triage by Developer.
dd (buggee) updated the task description. (Show Details)
dd (buggee) set Type to Bug.
dd (buggee) added a subscriber: dd (buggee).

I can't reproduce on linux64, will try on windows later.

@Antony Riakiotakis (psy-fi) I can confirm, Windows 8.1, Blender 2.72b 9e963ae. Smart UV project and cube project work, they just take a little bit. Straight UV Unwrap makes it go unresponsive and then crash.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Nov 7 2014, 8:56 AM
Bastien Montagne (mont29) updated the task description. (Show Details)

I can confirm that I cannot confirm that bug on linux64… :P

Martijn, Thomas, mind checking that on a win machine? Thanks.

Julian Eisel (Severin) triaged this task as Confirmed, Medium priority.Nov 11 2014, 8:19 PM

Can confirm on Windows 7 64 Bit.

Tested it and it works on my side (w7 SP1, 2.72b)

I can confirm the above described behaviour here on i7 Win7Pro 64bit w/SP1, with Blender 2.72b, 2.71, and 2.72.1 (Hash: 5c6e333) all ZIP builds: Blender crashes when UV unwrapping (all the UV unwrap modes work properly except for Unwrap). No crash if I dissolve the middle horizontal loopcut before unwrapping, but as soon I loopcut in the middle of the mesh and try to unwrap again Blender crashes. Below is the last portion of the console messages starting from the first attached test file opening:

read blend: C:\Users\[USERNAME]\Desktop\20141106_unwrapBug1.blend
read file C:\Users\[USERNAME]\Desktop\20141106_unwrapBug1.blend

Version 272 sub 2 date 2014-11-06 19:19 hash 0627bc2

ordered
OBCircle
OBCircle.001
OBLamp
OBCamera
ED_screen_refresh: set screen
DAG_id_tag_update_ex: id=OBCircle.001 flag=2
bpy.ops.object.editmode_toggle()
WM_operator_last_properties_store: storing properties for 'OBJECT_OT_editmode_to
ggle'
ED_undo_push: Toggle Editmode
DAG_id_tag_update_ex: id=SCScene flag=7
bpy.ops.wm.open_mainfile(filepath="C:\\Users\\[USERNAME]\\Desktop\\2014110
6_unwrapBug1.blend", load_ui=False, use_scripts=False)
WM_operator_last_properties_store: storing properties for 'WM_OT_open_mainfile'
Thread 0: update object OBCircle.001
recalcob Circle.001
recalcdata Circle.001
Thread 2: update object OBCircle
recalcob Circle
recalcdata Circle
Thread 0: total 1 objects in 0.000815 sec.

Circle.001 in 0.000815 sec

Thread 1: total 0 objects in 0.000000 sec.
Thread 2: total 1 objects in 0.000459 sec.

Circle in 0.000459 sec

Thread 3: total 0 objects in 0.000000 sec.
Thread 4: total 0 objects in 0.000000 sec.
Thread 5: total 0 objects in 0.000000 sec.
Thread 6: total 0 objects in 0.000000 sec.
Thread 7: total 0 objects in 0.000000 sec.
Tile size: 32x32 (30x17 tiles)
uiPupMenuInvoke: opening menu "VIEW3D_MT_uv_map"
wm_handlers_do_intern: handled! 'WM_OT_call_menu'
DAG_id_tag_update_ex: id=MECircle.001 flag=0
DAG_id_tag_update_ex: id=MECircle.001 flag=0

D:\Blender_2.72_stable>

Hope it helps.

Sergey Sharybin (sergey) closed this task as Archived.Dec 9 2014, 10:27 PM
Sergey Sharybin (sergey) claimed this task.

The issue is, there's no marked seems in the mesh, which makes the mesh to be rather tricky system of equations to b solved. Current solver uses recursive calls in some places, which makes it to run out of stack space and crash.

it's nothing we can do with current solver really, better to switch to LU solver from Eigen. For now just mark some seams to help the solver.

Thanks for the report, moving to a TODO now http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#UV_Unwrapping

Campbell Barton (campbellbarton) changed the task status from Archived to Resolved.Jul 21 2016, 10:21 PM

Using Eigen resolves this bug, closing.