Page MenuHome

Window doesn't update in Windows under high contrast mode
Open, NormalPublic

Description

System Information
Windows 8.0 Intel Graphics 4600

Blender Version
Broken: 2.72b
Worked: (optional)

Short description of error
Using this high contrast theme will cause blender to not open correctly and will not take commands for the mouse or keyboard

Exact steps for others to reproduce the error

  1. Use the attached theme for windows
  2. Open Blender

Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) set Type to Bug.
Aaron Carlisle (Blendify) created this task.
Aaron Carlisle (Blendify) raised the priority of this task from to Needs Triage by Developer.

sorry forgot to attach the theme{F122778}

Bastien Montagne (mont29) claimed this task.

Please do not use third-party windows themes with Blender, many of them are known to 'hack' into windows and hence to break Blender, which also needs access to the GPU (unlike most applications).

Mont29,
The attached theme is not a third party theme it is simply a high contrasts theme that I have saved into a file. So I know that it is not hacking my computer. However I do not know if turning on high contrast will disable some gpu functions such as OpenGL. I will Research and if I find anything i will reopen this bug.

Alright so I did some research and apparently when you turn on high contrast it disables desktop window manager. However there should be a possibility that it could be coded around.

I found this out from this forum
http://en.sfml-dev.org/forums/index.php?topic=12101.0

Martijn, Sergey, is this considered a bug? I don’t think so, but…

Update:
Blender will not work if you turn on high contrast then open Blender. However if you open Blender then turn on high contrast it will work.

Bastien Montagne (mont29) closed this task as Archived.Nov 14 2014, 9:32 AM
Bastien Montagne (mont29) claimed this task.

I do not see the point in keeping this open much longer, we cannot do anything about it currently, this sounds like MS bug to me anyway.

Campbell Barton (campbellbarton) renamed this task from Blender not responding to commands to Window doesn't update in Windows under high contrast mode.

While contributing to another OSS project afflicted of the same, I found the cause for this and the solution.

As Microsoft explains in a document about compatibility with high contrast themes for Windows 8 and up the executable manifest must have certain items.

I applied those changes to the manifest of the application I'm contributing to and now it renders perfectly under a high contrast theme, when it did not show anything before the change.

I have just registered on this platform just to let you know this since as a recent Blender user I'd like a lot to be able to work with it under HC.

Regards!

@Pedro J. Estébanez (RandomShaper), thanks for the heads up.

Could you link to the commit that resolved the issue for the other application?

For a quick test create a blender.manifest file at the Blender installation directory with this content:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly manifestVersion="1.0" xmlns="urn:schemas-microsoft-com:asm.v1" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
        <security>
            <requestedPrivileges>
                <requestedExecutionLevel level="asInvoker" uiAccess="false"/>
            </requestedPrivileges>
        </security>
    </trustInfo>
    <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
        <application>
            <!-- Windows 10 -->
            <supportedOS Id="{8e0f7a12-bfb3-4fe8-b9a5-48fd50a15a9a}"/>
            <!-- Windows 8.1 -->
            <supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}"/>
            <!-- Windows 8 -->
            <supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"/>
            <!-- Windows 7 -->
            <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
            <!-- Windows Vista -->
            <supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"/>
        </application>
    </compatibility>
</assembly>

Now, as long as the manifest tool is in the PATH:

mt -manifest blender.manifest -outputresource:blender.exe;1

Then switch to a high contrast theme, run blender.exe and see it working. :)

so we should add this, thx for doing the research

Sergey Sharybin (sergey) triaged this task as Normal priority.Jun 28 2016, 9:52 AM

@Martijn Berger (juicyfruit), @Bastien Montagne (mont29), are anyone of you looking into creating such a manifest? We can probably skip mt and ship manifest as a file next to executable for the simplicity?

Erf, this was only assigned to me because I archived that task two years ago! :P

Think this is task for platform maintainer ;)

At Godot we have found issues on some old graphics card with the enhanced manifest.

You can follow our research at the page for the issue.

Anyway, I'll post here what we find.

The setup known to give issues with Godot (Intel HD Graphics 3000 on 32-bit Windows 10) fails also for Blender with the modified manifest. It complains about no h/w acceleration.

That card is not officially supported for that platform so that is more or less expected.