Page MenuHome

Shrink/Fatten Bug | Modeling, Edit Mode, Polygons
Closed, ResolvedPublic

Description

System Information
Windows 7 Ult 64
GeForce GTX 580 1.5GB

Blender Version
Broken: All versions
Worked: Never

Short description of error
Edit Mode | Polygons
Weather you'd consider it a bug or a missing feature, Shrink/Fatten does not have desired functionality for Hard-Surface poly modeling. Provided video demonstrates the issue.
http://vimeo.com/111695386

Exact steps for others to reproduce the error
Described in the video.

Details

Type
Bug

Event Timeline

0rAngE (undo) raised the priority of this task from to Needs Triage by Developer.
0rAngE (undo) updated the task description. (Show Details)
0rAngE (undo) added a project: BF Blender.
0rAngE (undo) set Type to Bug.
0rAngE (undo) added a subscriber: 0rAngE (undo).
Campbell Barton (campbellbarton) closed this task as Invalid.EditedNov 13 2014, 9:27 AM

holding Alt will activate a method that takes thickness into account. (gives better results)

further, the feature is working as intended.

(Probably best you give text description too, I couldn't hear audio for the video you linked to, but this seems more like a request for a feature / change in behaviour then a bug)

Has anyone watched the video? I believe it demonstrates clearly what I'm trying to say.
I know about the ALT-key modifier for Shrink/Fatten (and Extrude).

I'm gonna make a guess here, I might be wrong as I'm not a programmer.

The issue is that the vectors for the transforms are always calculated by vertex normals.
But the Tools should be context sensitive. In turn, in Vertex mode it would behave as it currently does. But when in Face mode the vectors for the transforms should be calculated by face normals.

In the video I have provided examples of 2 other applications that have the desired functionality.

Campbell Barton (campbellbarton) changed the task status from Invalid to Resolved.Nov 13 2014, 4:54 PM

This is really a feature request, so we typically close those immediately.

This has been suggested before, and guys here in the studio think its useful, so I've committed it.

Committed rB1ddfe6676de1b382d2c9b06cc9c68f50659d13de

Thanks on clearing it up, much appreciated!

If someone finds the time to implement this, would it be possible for someone to refer back to this 'Task Thread' and post?
Would love to be aware of this if implemented!

@0rAngE, not sure what you mean, its implemented now isn't it?, did you try a recent build?

Just tried a recent build from buildbot.

WOW!
...speachless.

Perfect.
Thanks!!!!!!!!!