Page MenuHome

Poor cycles perfofmance in blender-2.72.2 than in blender-2.72.1
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
Gentoo amd64 laptop
Asus G75V with gtx660m
and
Gentoo amd64 desktop
i7-3...* dual gtx780
Blender Version
Broken: git
Worked: blender-2.72.1 (last 2 weeks from git http://wstaw.org/m/2014/11/15/plasma-desktopgL2782.png )
Short description of error
http://blenderartists.org/forum/showthread.php?239480-2-6x-Cycles-render-benchmark&highlight=benchmark+bmw
With blender-2.72.1 i have render time 2 min 45 sec
With blender-2.72b i have render time 3.30
With blender-2.72.2 git i hane render time 3.40
Why?
ps: i have a nvidia-cuda-toolkit-6.5.19
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Not sure this is actually a bug… though variation sounds strange to me. Sergey, Thomas, hints?

We had quite a few changes since 2.72b http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.73/Cycles

Nevertheless, I can't imagine why 2.72.1 would be *faster* than 2.72b. We did not had changes which would explain such a big speed up. On the contrary, Camera in Volume, Area sampling changes.., should make it a bit slower. So the 2.72.2 rendertime seems realistic to me.

Edit: Didn't see the bmw scene link.

Thomas Dinges (dingto) triaged this task as Needs Information from User priority.Nov 15 2014, 9:43 PM
Thomas Dinges (dingto) raised the priority of this task from Needs Information from User to Normal.

Thank you for answers
An another bug i found between this versions
in new bledner builds from git lost drag-n-drop from de (files/textures) (in kde)
in bledner-2.72.1 on screenshot - all fine agane
in blender from builder - all fine

Please help me to solve this troble

system info http://www.pasteall.org/55257

if it need more info please tell me

Sergey Sharybin (sergey) lowered the priority of this task from Normal to Needs Information from User.Nov 26 2014, 10:59 AM

The splash screen clearly shows you're using some unofficial build with patch applied. For such builds we can not guarantee anything.

Here's an official build of the same revision as on your splash screen (as i understand, that's the one which worked fast for you): ftp://ftp.blender.org/sergey/linux-c8d10d1-glibc211-x86_64.tar.bz2 | linux-c8d10d1-glibc211-x86_64.tar.bz2

Please compare that build with the latest builds from builder.blender.org.

Hellow, Sergry. Thank you for answer.
I tested c8d10d1 build on BMW scene
There is result - 2 min 48 sec
And there are results of my builds
c8d10d1 - 2 min 44 sec
today git - 3 min 22 sec

Sorry for typo in previous post
i just build blender from git and drag-n-drop is wirking!
Thank you for fix

ps: cycles speed is still low...

Hello
I found a performance bug
if was, as i think, compiling cuda kernel when blender cycles run in first time (that was for mine later builds)
in builder's builds cuda kernels are already compiled, and this get a good pesformance
but why that happend's i don't know
may be this parameters give effects too
-DCUDA_BUILD_CUBIN=ON
-DCUDA_SEPARABLE_COMPILATION=ON

Thank you for devdeloping a best software!

So am i right using cubins from the builds from blender.org gives good render times and using your owns gives bad one? If so, which cuda toolkit you're using?

Plus, in your reply from 27th Nov, where you told our build of c8d10d1 gives good performance, did you measure it with own builds or builds from builder.blender.org?

And just to be sure, are builds from builder.blender.org good?

Hello
I have nvidia-cuda-toolkit-6.5.19
Builds from builder.blender.org from have best performance for me
Second place is my live builds from git (~2% slower (i think becaise i have gcc-4.9.2)
Third place is my build andd build from blender.org (~5% slower)

My old build c8d10d1 was better than later svn builds because i update gentoo's building script
from
https://github.com/megabaks/stuff/blob/master/media-gfx/blender/blender-9999-r1.ebuild
to
https://github.com/megabaks/stuff/blob/master/media-gfx/blender/blender-9999.ebuild
(i modified code of official script http://data.gpo.zugaina.org/gentoo/media-gfx/blender/blender-2.72b.ebuild
(because it is not cuda support))
AND it was wrong! because i get bledner build with low speed of cuda in cycles (i dont know why? i'm don't coder, but i think this is because cuda kernels compiled in first render time)

Now i switch to my old build script and get back optimal cuda speed.
https://github.com/megabaks/stuff/blob/master/media-gfx/blender/blender-9999-r2.ebuild

Sorry for noise
and thank you

Julian Eisel (Severin) closed this task as Invalid.Dec 2 2014, 11:45 AM
Julian Eisel (Severin) claimed this task.

Soooo, seems like this can be closed? Rhetorical question, already did so ;P Feel free to reopen in case I interpreted your comment wrong

Hi, so as I've said in my previous thread, I use only build from http://download.blender.org/release/ and the last with good performance is 2.70 2014-Apr-12 09:43:17.
I've tried also latest build from https://builder.blender.org/download/ still the same problem.
My original thread with this problem
https://developer.blender.org/T42764

Thanks for help

@Jarda Pribyl (mooonwalker), some questions:

  • Could you confirm at your current system 2.70 release works much faster than 2.72b release and current build from buildbot? (to be sure it's not some driver update caused the issue somewhere in the past)
  • Which driver do you use?
  • Any chance of you trying to reproduce the issue on another computer?
  • Actually what I've noticed is that if in User preferences - Compute device - Cuda = I have 3 options GeForce GTX 590 (2x) then GeForce GTX 590 and GeForce GTX 590.

If i chose one of GeForce GTX 590, render time is about 1:30 and in render window, I can see it renders one tile at the time. But if I switch to GeForce GTX 590 (2x) it tries to render 2 tiles at the time, but then it freezes.
with one of GeForce GTX 590 looks like this
with GeForce GTX 590 (2x) looks like this and this is screenshot made after 2 minutes have passed inrealtime since I hit render. But blender counter seems to stuck at 6 seconds.
In 2.70 from blender.org - older versions, if I set it to GeForce GTX 590 (2x), works fine and I get time 0:43.

  • I'm using 344.75 GeForce GTX 590 driver
  • I don't have any other PC here, so can't reproduce it. But on my laptop with Nvidia 540M it works ok. But As i said, it look that the problem is setting it to 2x

Thanks

My skype is mooonwalker814

Maybe I'm little paranoid, but here's what I find from last post.
I've tried to run again render in 2.70 from blender.org with 2x option on GPU, and it does the same as 2.72. Only 2 tiles and than it freeze.
So I've restarted my PC, run it again and it rendered the scene in 0:43.
Great, so I try v2.71 from blender.org, and it rendered in 0.49(slight decrease in speed but still good), than I've tried 2.72b and the render freeze(well not freeze but remaining render time is about 2 hours).
Than I tried again 2.70 and 2.71 and it works. With that result I opened Mozilla Firefox and 2 random tabs. I hit render on 2.70(version that works OK) but now, same story , render freezed only at 2 tiles. So I closed Firefox, hit render again(still v2.70 or 2.71) and everything worked OK. Interesting.
Ver. 2.72 and higher are still issue.
This problem, with open browser only occures with Firefox. Maxthon and IE works OK.
Oh and if I hit render in 2.70/2.71 without Firefox open, my system still functioning properly while rendering. But when it renders and have this issue(2.70/2.71 + Firefox or 2.72 and above) my system is totally frozen.
Oh and this Firefox thing is also appears only with 2x option on GPU. With single core, everything looks OK

That's all correct that two tiles appears, but it shouldn't stuck..

Did you try installing latest video drivers from nvidia site?

Maybe this is an SLI problem... Do you have SLI enabled in your nvidia control panel ?

sergey: nvidia site shows as latest divers this http://www.nvidia.com/download/driverResults.aspx/79891/en-us , which is the same driver as i've got on my PC. I've tried clean instal of drivers, but problem is still there.

lordodin: My nvidia control panel looks like this, http://jaroslavpribyl.com/wp-content/uploads/2014/12/ncp01.jpg . I found some tuts on web about how to disable sli, like this one here http://www.computerhope.com/issues/ch001167.htm . So don't know if there is that option, because I've got only one card(but its dual core).

Your SLI is on click this to disable it.

WOW thanks, it's working.
Case closed
Thank you all for help
Have a nice day