Page MenuHome

Laplacian Smooth modifier calculated even if object visibility is turned off
Closed, ArchivedPublic

Description

System Information
Win 7 x64

Blender Version
Broken in 1103abd (Gooseberry branch)

Short description of error
Having a laplacian smooth modifier on an object severely slows down armature movement even if the object itself has its visibility turned off. Makes working with armatures affecting multiple objects incredibly tedious.

Exact steps for others to reproduce the error
Add armature to an object, add laplacian smooth modifier, turn off object, adjust armature.

Details

Type
Bug

Event Timeline

Matt Heimlich (m9105826) set Type to Bug.
Matt Heimlich (m9105826) created this task.
Matt Heimlich (m9105826) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

As usual, please attach a .blend file to help us reproducing the issue…

Hrmmm… so, looks like mod stack of object is updated even if object is not visible… Would say this is expected behavior though (else, if some other object was dependent of hidden one somehow, it would not get updated either, even though visible).

Sergey, Campbell, thoughts?

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Nov 17 2014, 12:58 PM
Sergey Sharybin (sergey) closed this task as Archived.Nov 18 2014, 11:03 AM
Sergey Sharybin (sergey) claimed this task.

This is a limitation of current dependency graph, it uses layer visibility instead of object visibility to distinguish which object the update flag flush should happen. This is because visibility flags could be different for render and viewport and layer visibility is the same.

For now you should just move the heavy object to another layer.

This is a nice feature to support in the new dependency graph, but old one better not to be stressed more.

So thanks for the report, but considering it a TODO.