Page MenuHome

VSE Gaussian Blur on 2 axes Full Load CPU
Closed, ArchivedPublic

Description

System Information
Windows 7 x64, GTX 580 3Go, i7 3770k, 8go ddr3

Blender Version
Broken: 2.72b 9e963ae
Worked: (optional)

Short description of error
VSE effect strip Gaussian Blur, take cpu to full load when 2 axes are active

Exact steps for others to reproduce the error
Open Blender
Go to Video Editing
Add effect strip: color (to test the gaussian blur, you can test with image or video it's the same)
Add effect strip: gaussian blur (to the color strip)
On properties panel (N) put x size to 100 and y size to 100
The CPU is full load and blender take some time to be responsive again

Note: If you put 1 gaussian effect strip for x and an other one for y it didn't full load the CPU

Details

Type
Bug

Related Objects

Event Timeline

Greg (mareck) set Type to Bug.
Greg (mareck) added a subscriber: Greg (mareck).
Greg (mareck) created this task.
Greg (mareck) claimed this task.
Greg (mareck) raised the priority of this task from to Needs Triage by Developer.
Greg (mareck) removed Greg (mareck) as the assignee of this task.Nov 27 2014, 5:38 PM
Aaron Carlisle (Blendify) triaged this task as Normal priority.Nov 27 2014, 6:30 PM

I know that the blur effect does take up a lot of CPU. I don't use this feature because of this I tend to use the compositor instead. I don't really know if this is a bug though. However the blur effect strip can be optimized a lot.

I can confirm that Gaussian Blur effect is extremely slow. Interesting is that Glow effect is faster. Looking at the code, it seems that Glow effect is two effects mixed, one of them being blur....?

Sergey Sharybin (sergey) closed this task as Archived.Dec 2 2014, 2:00 PM
Sergey Sharybin (sergey) claimed this task.

It is possible to optimize blue effect strip, but that'd be handled outside of the bug tracker.

So thanks for the report, but archiving it now.