Page MenuHome

X axis mirror - Armature no longer allows right click to confirm
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
Mac OSX 10.8
NVIDIA GeForce GTX 470

Blender Version
Broken: version 2.72b

Worked: 2.71

Short description of error
It is no longer possible to mirror the armature across the x axis and right click to confirm the original position of the bone
(you must confirm with left click which changes the position of the selected bone)

Exact steps for others to reproduce the error

Select a ".L" bone in edit mode of an armature
activate "X axis mirror"
move the bone and then right click to cancel
(in 2.71 and previous, it used to snap the bone back to the unchanged position and move the ".R" bone to the mirrored location)

short video explanation

Details

Type
Bug

Event Timeline

Wayne Dixon (waylow) set Type to Bug.
Wayne Dixon (waylow) created this task.
Wayne Dixon (waylow) raised the priority of this task from to Needs Triage by Developer.

Will have a look asap

Julian Eisel (Severin) triaged this task as Normal priority.Dec 10 2014, 8:56 AM
Julian Eisel (Severin) closed this task as Invalid.Dec 12 2014, 3:00 PM

Had a look at it, but think this is an intended change. I'd consider the previous behaviour more as a bug, since it resets the bone position to the location that is wanted from the x-axis mirror operator, rather than it's initial position. I didn't find a dedicated commit on a rough search, but anyway, I think the current behaviour is better UX-wise.

Nevertheless, thanks for the report @Wayne Dixon (waylow) :)

I disagree, the current behaviour makes it an almost useless tool.

It is very annoying to change the position of the bone just to mirror it as this can break a rig with constraints.
(usually the bones are in precise positions and can be complicated setups before you mirror them)

Julian Eisel (Severin) reopened this task as Open.

Okay, good point. So think issue lies in the rigging code...
@Joshua Leung (aligorith) not sure if rigging is your area, if so, mind having a look?

Thanks for having another look at it :)

It was an intended change to fix this other user's bug:
https://developer.blender.org/T40991

The tool is still useful, just use G 0 enter instead of G esc
We had a long back and forth (I was initially against the change, ) before fixing.

Julian Eisel (Severin) closed this task as Invalid.Feb 2 2015, 2:51 AM

Okay, so we have an intended change plus a workaround for people that want the old behaviour. I guess everyone is happy then? ;)