Page MenuHome

Knife Project bad precision
Closed, ResolvedPublic

Description

System Information
Windows 8.1 x64
Renderer: GeForce GTX 860M/PCIe/SSE2

Blender Version
Broken: 2.72.2 c8995ec

Short description of error
Knife Project tool gives unexpected results depending on zoom level and global objects position. Some artifacts could be evaded by moving objects slightly right or increasing/reducing zoom level, but if somehow I managed to escape one artifact, another pops out.

This tool would be very handy in product/jewelry design if it will be predictable and stable.

Exact steps for others to reproduce the error

  1. Open blend file
  2. See examples for unexpected results, and use test models for tests

Here is few screenshots:

Event Timeline

Mikhail Rachinskiy (alm) set Type to Bug.
Mikhail Rachinskiy (alm) created this task.
Mikhail Rachinskiy (alm) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) reopened this task as Open.EditedDec 15 2014, 6:18 PM

Thanks for the comprehensive report.

Fixed 2 of the issues:


There is still an issue when cut-through is enabled. I think this is the issue you refer too


Note that you can workaround this by rotating the model slightly, the issue seems to be caused by 2x intersections on different edges overlapping exactly.

Campbell Barton (campbellbarton) closed this task as Resolved.

Closed by commit rB72341537e872.


Note, all of the reported issues are fixed now from what I can tell, it even fixes some issue you didn't report :)

Big thanks! Test cases are perfectly handled.
But I still get artifacts:

In this case it's selection and cut artifacts, very rare to catch, usually fixed by moving viewport.
To reproduce open blend file and press Knife Project.

This is selection only artifact, cut is alright.
To reproduce open blend file and shake the viewport a few times to get rid off previous artifact, and eventually you'll get this one.

The same as previous — selection only artifact.
To reproduce open blend file, and try test set to the left from current one.

Could this be a weak design of Knife Project tool? So it doesn't matter how much you try, there is always be a possibility for an artifact?

Test file

@Mikhail Rachinskiy (alm), project_knf_2.blend is really related to T42459, so leaving this report closed & linked to the test-cast from there.

That cutting at large or small scale will give problems. Its a real bug but unrelated to the other problems.

Id rather leave this for after 2.73 release.