Page MenuHome

Panning in Sculpt Mode with tablet messes up 3d view.
Closed, InvalidPublic

Description

System Information
Mac OS Yosemite - NVIDIA GeForce GT 650M 1024 MB

Blender Version
Broken: 2.73
Worked: I can't remember, it's been so long. Sorry about the late report.

Short description of error
When I’m in Sculpt Mode and I’ve begun sculpting with my tablet, whenever I try to use the pan function, the object flies away from my view, until I press “fn” + “option” + "left arrow” to bring it back into focus.

Exact steps for others to reproduce the error
Open any scene. Switch to Sculpt Mode. Plug in tablet. Sculpt one or more strokes. Press "Shift" + "Option" then Click mouse and drag. The 3d view should move far away from the object, putting it out of sight.

Here's an example -
https://www.youtube.com/watch?v=T7vOZB0u3qI&feature=youtu.be

Details

Type
To Do

Event Timeline

Brandon Farley (farcgs) raised the priority of this task from to Needs Triage by Developer.
Brandon Farley (farcgs) updated the task description. (Show Details)
Brandon Farley (farcgs) set Type to Bug.
Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jan 3 2015, 5:52 PM

As far as I can tell, the problem is tablet in absolute mode in combination with Continuous Grab. Optimally, Continuous Grab would be disabled for transformations if you're using a tablet.

I wanted to investigate this a bit further, too see what I can do code-wise, but after changing the tablet mode once, the problem didn't appear anymore (even after setting it back to absolute again). So chances are this is a driver issue (well even if so, I wouldn't deny that Blender's tablet support could be improved, but that's a different story and shouldn't go in here).
So could you just test if changing the tablet mode to relative and back again helps? If not, we'd need to investigate this a bit further.

I changed the mapping mode from "pen" to "mouse" and back and the problem still occurred.

mhh, okay, am I right that it works fine if you disable Continuous Grab (User Preferences->Input)?

Oh yes, that seems to fix it. Thank you.

Well, but that's no nice solution IMO. I'll see what I can do

Julian Eisel (Severin) raised the priority of this task from Needs Information from User to Normal.Jan 6 2015, 11:13 PM
Julian Eisel (Severin) closed this task as Invalid.Jan 11 2015, 6:52 PM

Actually, I'd prefer this to be handled as a Todo -> Moved to Todo list: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/UserInterface#Tablet_Support

Julian Eisel (Severin) changed Type from Bug to To Do.Jan 11 2015, 6:52 PM