Page MenuHome

Circle Select | PASS_THROUGH Navigation
Closed, ArchivedPublic

Description

System Information
Win 7 Ult 64
GeForce GTX 580 1.5GB

Blender Version
Broken: -
Worked: never

Short description of error
I know this falls under "works-as-intended", I'm still throwing it out as a reminder of a feature that is half functional.

Can not navigate when Circle Select is invoked.
Why not use the same paradigm as with Knife Tool, and PASS_THROUGH navigation. Have a drop down to choose "Panning" that will allow (even custom navigation) to PASS_THROUGH the Circle Select. Basically same principle as with the Knife Tool.

As is, it's really hard to use Circle Select effectively, as you have to constantly exit and re-enter the tool in order to complete desired selection. Because you have to navigate the model to achieve it.

One thing at the time, that would be most important!
Another useful thing would be to set the Circle Size like the sculpt Brushes - with one hotkey+mouse gesture. Like the Sculpt Brush Size, F + LMB (drag L / R). I would imagine that wouldn't be too big of a deal, as the code is already there.

I apologize again, because this is one of those situations that could go either way bug<>works-as-intended. I do believe that it would enhance the productivity of the Circle Select so much that I felt I would draw your attention to it.

Thanks.

Exact steps for others to reproduce the error

Details

Type
To Do

Related Objects

Event Timeline

0rAngE (undo) raised the priority of this task from to Needs Triage by Developer.
0rAngE (undo) updated the task description. (Show Details)
0rAngE (undo) added a project: BF Blender.
0rAngE (undo) set Type to Bug.
0rAngE (undo) added a subscriber: 0rAngE (undo).

This is something I'd like to look into soon, therefore setting it as a Todo (this really is no bug). I'm not sure if it's as easy as just returning PASS_THROUGH, but I'll investigate this.

Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Normal.Jan 14 2015, 8:02 PM
Julian Eisel (Severin) changed Type from Bug to To Do.

Main problem is, that MMB is already used for unselecting, so we'd have to find a different shortcut for that. @venomgfx, @Jonathan Williamson (carter2422), @Paweł Łyczkowski (plyczkowski), what do you think? Maybe CTRL+MMB or RMB?

Julian Eisel (Severin) closed this task as Archived.Sep 5 2015, 8:15 PM

Closing this for now. It's part of the keymap revamp (T37417), it's not just a matter of returning OPERATOR_PASS_THROUGH.