Page MenuHome

Collada: No Bi-Normal support
Open, NormalPublic

Description

System Information
Windows 8.1
Ubuntu 14.10

Blender Version
2.7

Short description of error
Blender Collada exporter does not export vertex binormals within the Collada document.
This is mandated by the Collada specification (Page 17)

Exact steps for others to reproduce the error

  1. Create scene
  2. Select file -> export -> to Collada (.dae)
  3. Open exported file with any text editor
  4. Does not contain binormal data

    Note: Merged in all Collada bug reports here. please check all merged reports & close as resolved when fixed.

Details

Type
Bug

Event Timeline

Trevor Westphal (tsoccer93) raised the priority of this task from to Needs Triage by Developer.
Trevor Westphal (tsoccer93) updated the task description. (Show Details)

And again, some more work for @Gaia Clary (gaiaclary) ;) (might easily be a Todo though)

Sergey Sharybin (sergey) closed this task as Archived.Jan 20 2015, 11:43 AM

Collada importer/exported does not currently have maintainer so all the issues goes to the TODO list there http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export

Thanks for the report anyway!

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Jan 20 2015, 2:18 PM
Brendon Murphy (meta-androcto) renamed this task from Collada Export does not include Vertex Binormals, to Collada: All Bug Reports.Sep 8 2015, 4:52 AM
Brendon Murphy (meta-androcto) triaged this task as Confirmed, High priority.
Brendon Murphy (meta-androcto) updated the task description. (Show Details)

Merged in multiple reports on collada i/o, please use this task merging individual reports & close merged tasks as resolved as they are individually fixed. future reports should have new task & will be merged here once received.

@Brendon Murphy (meta-androcto), these reports aren't "duplicates" of each other.

We have a Collada project to collect these (see: https://developer.blender.org/tag/collada/).

Moved all collada reports into the "Collada" project, removed "Addons" and "Blender" projects.

Campbell Barton (campbellbarton) renamed this task from Collada: All Bug Reports to Collada: No Bi-Normal support.Sep 8 2015, 5:33 AM
Campbell Barton (campbellbarton) lowered the priority of this task from Confirmed, High to Normal.

note to self:
It looks like the export can be done in a straight forward way, see rna_Mesh_calc_tangents().
The FBX exporter does it similar to this:

me=bpy.context.edit_object.data
uvname = me.uv_layers.keys()[0]
bitangents=[0]*len(me.loops)*3
e.calc_tangents(uvname)
me.loops.foreach_get("bitangent", bitangents)

I add this task to my feature request list for now.