Page MenuHome

Math node - result is 0
Closed, ArchivedPublic

Description

System Information
CentOs, Intel graphics chip

Blender Version
Broken: 2.72b 9e963ae

Short description of error
If I try to print the result of a math node via python, I always getting 0.

Exact steps for others to reproduce the error

  1. Create 2 value node with different values
  2. Some math (e.g. subtract both values)
>>> bpy.data.materials['Material'].node_tree.nodes['Math'].outputs['Value'].default_value

Result:

>>> 0.0

Details

Type
Bug

Related Objects

Event Timeline

Christian Brinkmann (poor) created this task.
Christian Brinkmann (poor) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.Jan 24 2015, 1:45 PM
Sergey Sharybin (sergey) claimed this task.

You can not evaluate nodes from python, it's just not supported. Default value is only valid for input sockets and indicates the input value f there's no links. But because sockets shares some underlying logic output socket also does have default value, which is just unused.

Thanks for the report, but it's not a bug.