Page MenuHome

Light groups lit all the materials on different scenes
Closed, ArchivedPublic

Description

System Information
Win 7
nvidia 460

Blender Version
Broken: 59e2f91

Short description of error

when a light group its used in a Blender internal material in X scene it automatically lits all the materials on the others scenes

Exact steps for others to reproduce the error
1-open


2- Set the light group of the with plane with the Group (Group its the group of the sun light)
3-Go to the scene "Scene" and render
4- you should see the red plane,
the thing its that in that "Scene" there isnt a light, its being lit by the sun on the scene "SCENE-2"
5-erase the light group from the material on the plane white on the "SCENE-2"
6-Now try to render the red plane, it should render black

Details

Type
Bug

Event Timeline

Nahuel Belich (belich) set Type to Bug.
Nahuel Belich (belich) created this task.
Nahuel Belich (belich) raised the priority of this task from to Needs Triage by Developer.

confirmed, this is weird indeed:

i firstly assumed that light groups can be reused across all scene since you can set groups from other scene, but it does not work unless you link light from that group to current scene
and its on visible layer

so in this case light from other scene is litting all scenes

ok i fell a bit dumb because its weird but it works as it use to worked on blender 2.49 just cheked, sorry

http://wiki.blender.org/index.php/Dev:Ref/Outdated/Release_Notes/Modeling/Objects/Groups_and_Parenting#Light_Groups

""Light Groups
In the Material buttons (F5) Shading panel, you can indicate a Group of Lamp Objects to be used as light for rendering, instead of the usual visible Lamps. This actually enables per-Material lighting (independent of which Object has the Material, or whether the Lamps are in visible layer).
If you don't want Lamps from a Light Group to work on the other Objects, just move them to an invisible layer.""

if i understand right this should be named as "global lights groups", witch adds each light in the selected groups as global lights, so if i have an scene with three lights and a group fot each light i will be litting all the scenes with those three lights plus the rest

Sergey Sharybin (sergey) closed this task as Archived.Jan 27 2015, 2:37 PM
Sergey Sharybin (sergey) claimed this task.

Light groups weren't actually intended to be used in multi-scene scenario -- there's no proper check for whether material is used or not. Improvements here are possible and would be nice to be done, but it'll be handled as a part of TODO list work: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Render#Render_Engine

Thanks for the report, but closing as a TODO now.

i would suggest to have "exclusive" to be checked by default, in most cases its what you expect and works well with multiscene setups