Page MenuHome

Project marked as saved when saving a copy.
Closed, InvalidPublic

Description

System Information
Ubuntu 14.04
GeForce GTX 480/PCIe/SSE2

Blender Version
Broken: 2.73a bbg09d9
Worked: (optional)

Short description of error
The star in the window menu bar indicating that the project has unsaved changed dissapears when Save_Copy... is used.

Saving a copy should in no way alter the parent project, including it's saved status. The currently open project is actually not saved even if indicated so.

Exact steps for others to reproduce the error
Save an altered project as a copy. See the * disspear. Reopen your project, see your changes lost. Try to rescue your work by retrieving your temporary copy done for render purposes, find it deleted by your render script. Redo work.

Details

Type
Bug

Event Timeline

David Rylander (animationista) raised the priority of this task from to Needs Triage by Developer.

Hey there,
The "*" indicator is really only used to help the user indicate if a project is saved at it's current state or not. If you save a copy, this is as equally saved as normally, just to a different file. If you have a script that deletes such files it's not our "fault".
(More on file saving is described here)

So thanks for the report, but no bug here since everything works as intended.

Julian Eisel (Severin) closed this task as Invalid.Feb 5 2015, 2:28 PM
Julian Eisel (Severin) claimed this task.