Page MenuHome

Inconsistent use of terms for "Properties Region"
Closed, ResolvedPublic

Description

This has been a concern of mine for a long time, but now that I'm documenting the manual I'm finding it even more difficult to know what term should be used when referring to the Properties Region (aka "N-panel", "properties panel", "properties bar", "N-shelf" etc...)

I would like to propose that we make a formal decision and stick to it, both in tooltips and the user manual.

At the moment I'm under the impression that "Properties Region" is the correct term - if so, here is a patch which hopefully corrects all the tooltips and code comments in Blender which refer to it as the "properties panel" (note: although I do not know for sure what to call it, I do know that it is most definitely not a "panel"): http://www.pasteall.org/56638/diff.

And here is a similar patch which corrects the Addons-Contrib repo: http://www.pasteall.org/56637/diff - I found no obvious issues in the regular Addons repo.


My thoughts are that we should move away from the word "properties", as this is already used for the Properties Editor and has thus caused plenty of confusion.

Details

Type
To Do

Event Timeline

I wrote something about that a few years ago. http://temp.dingto.org/UI-Book.pdf See chapter 2. That is not official, but would be good to have some guidelines.

Yes, I think currently "Properties Region" would be the correct term. Not sure if there was an official decision about this, but at least from the code this would be a region with the name "Properties" so calling it "Properties Region" seems right.

But anyway, I agree that having both a Properties region and a Properties editor is highly confusing so +1 for changing either the region or the editor name.

It's not easy to find a good alternative, but let me propose two ideas:

  • Leave the Properties Editor called "Properties" and call the Properties Region "Editor Settings"
  • Call the Properties Editor "Global Properties" and the Properties Region "Editor Properties"

I don't have any better ideas, but just to be critical:

  • "Editor Settings" implies that it contains only the settings for the editor itself, however it also contains settings for the selected objects/components.
  • "Editor Properties" has the same issue.
  • "Global Properties" has a similar issue, in that it's not only the properties of the scene but also of the active object and therefore not "global".

It is true that it contains settings for the selected object/component. But it should be only active object/selected component visible in the editor.

If you have 2 unsychronized 3D viewport (one that display active object and the other one that don't), item panel is only visible in the viewport that display active object.

I know that Transform panel is always visible. For me, Transform panel does not respect initial design idea.
Many people think that it is redundant with transform panels in Properties Editor.
But it is not limited to object and also show selected components properties in edit mode (which are not visible in Properties Editor).

For me, it should be Editor/Selection Properties.
It is a long name but not so surprising when you are used to UV/Image Editor.
Unfortunately, Transform panel does not respect that, either. It is limit to one object settings with a multiple selection in object mode.

Some thoughts:

it's a region, it's for properties... so properties region sounds clear to me, and there are panels inside of it...

the properties editor is an editor area.. it too can have subregions at some point ( working on a proposition for that... )

The main thing i want to add here is don't forget that most editors also have a properties region.

ie, in the nodes editor, uv/image editor,...

Looking at the header view menu some more things come up :

Why do we call the one a region and the other a shelf ? tools region then ? maybe in the header we can just put 'tools' and 'properties' under the view menu.

or just have left and right region, with by convention right is for properties, and left for tools. maybe some day we have a bottom / top region in an area (ignoring the header for now...)?

-that would also mean, that for the text editor it should be on the right....
-also, in the 3D view, i feel that current operator settings should not be a 'subregion of the toolshelf region' (there we go again...) , but as a panel in the left properties region, since it is for properties of a tool, not a tool in itself.

Defintely don't call it the n or t panel in docs, since shortcuts can change!

So i would refer to it as just 'properties region' when talking about an editor, and if you refer to it when talking about some other editor, you have to specify the editor, ie 'the 3D-View properties region' ... a bit verbose but clear in scope.

edit: thinking this through, you could actualy leave out region altogether when everything is more consistent, in left and right regions. So you just say 'properties region', meaning the region of the editor you talk about. if you mean the editor, 'properties editor'. using specific scope '3d-view-editor properties', node-editor properties, etc

another thing i think about is how with the python api? some editors do'nt have a tools region, but maybe all the editors ( apart from some obvious column ones) should have both regions, then some addons could make use of them.

edit2: maybe we stick to much to the technical term of the windowmanager 'region' and could use a more gui related name for instance 'sidebar'; properties sidebar and tools sidebar. properties editor is clearly another beast then. You then refer to a specific one as 'properties sidebar in the nodes-editor'.

Using the terms "Right -" and "Left Region" also wouldn't be good solution since you can swap the region side by hovering it and pressing F5 (Flip Region).

You brought me the idea of calling the properties region "Editor Shelf" which I quite like. At least we can get rid of the term "Properties" then and it's consistent with the "Tool Shelf". Of course not the ideal solution but one that we could live with IMHO.

Why is the one on the right the "Editor Shelf"? It has just as much to do with the editor as the left one does ;)

I think "Properties" suits it well, and either "region" or "shelf" is fine by me.
So how about naming the Properties Editor something else? I usually refer to the Render context/tab/thing as the "Render Settings", and the other contexts similarly ("Material settings", "Particle settings", "Object settings"...), so how about naming it the "Settings Editor"?

Well the Properties Region is the one that contains the editor specific settings. Well... at least it should :P

The term "Settings" is also not really good as it's usually used by other apps for the app settings (like our User Preferences)

Trouble with 'properties' is that we already have a Properties window type called that. It'd create unwanted confusion if there are two different types of areas with the same name.

For this reason, 'Region Shelf' or 'region settings' is a better term.

Settings Shelf ?

seems ambiguous enough to cover all the contents and it's completely unique from 'properties editor'

hi,
The Tool Shelf includes Tabs & Tool Shelf Panels.
The Properties Shelf includes the Properties Shelf Panels.
This is consistent.
The word Shelf, correctly describes the menu style for these areas. Where confusion comes in is the wrong naming of the Properties Shelf such as Properties Region, Properties Area or any other wrong description. These become more confusing in context when describing the Properties Editor.
When & decision is made here I'll update all addons to make sure they follow convention.

1+ for Properties Shelf.

The issue with 'Properties Shelf' is that it might cause confusion with the 'Properties (Editor)'. So I'd really like to avoid the term 'properties' now (an overused term anyway).

Talked a bit with @Brendon Murphy (meta-androcto) on IRC and we agreed that 'Editor Shelf' seems like the best option. It really contains the settings for a single instance of an editor.
Alternatively we could use 'Region Shelf' but am not so keen about it since it might cause even more confusion between 'Area' and 'Region'.

The problem with Editor Shelf is that Tool Shelf is also generally an Editor Shelf.

I would go with Editor Settings Sidebar/Shelf, if not for the fact that some panels dumped in there are actually not editor related, like the Transform and Item panels.

I don't see a problem in using the word "Shelf" in UI or manual.
It would also make more sense to adopt the word "shelf" in Themes UI where header is opposed to region; that is not coherent with code.

Confusion is related to the word "Properties", anyways.
Before being in manual, Its origin is in Blender, itself.

It is the good way to go to create a design task for that.
But I don't think that Properties Shelf / Properties Editor differentation will be sufficient to avoïd it.
Properties Editor is also a shelf of panels.

+1 for Editor Shelf.

"Settings" is already used a lot in python data paths, too.
For example, we have ToolSettings.
https://www.blender.org/api/blender_python_api_2_77_1/bpy.types.ToolSettings.html#bpy.types.ToolSettings

We could try other synonyms: marks, aspects, peculiarities...

Editor Shelf is like naming it just shelf.
Don't know if it's a problem, that it isn't the only shelf.

Editor Shelf
Editor: Tool Shelf
Editor: Header

But it's better than Properties Shelf.

If you start using "shelves" then this image would need to change to include them https://www.blender.org/manual/_images/getting_started-basics_interface_introduction_05.png

Or else you have to rename the "tool shelf" to "tool region"

and

"properties shelf" to "properties region"

For me, I like properties/tools shelf/region. Either of these works and I do not see the confusion between a properties region/shelf and the properties editor. I guess the big issue is when we start adding per object settings to the shelf. So, I think we would be fine with either of the solutions if we remove these settings.

I actually started liking Properties Sidebar. It gives a nice hint to where you can find it without specifying left or right (which you can still change). And I think for everyone who has basic understanding of Blender's sub-windowing system it's obvious that this doesn't refer to the Properties Editor which can be placed everywhere.
The only thing it doesn't convey is that it's a per-editor region, but don't think that's needed really (toolshelf doesn't either).

So Toolshelf and Properties Sidebar?

I'm of course fine with, although it would be nice to hear what others say.
I'd still prefer a clearer distinction than Properties Sidebar and Properties Editor give us, but I think this is acceptable since we didn't find a solution that does this.

hi, I think this is close to being good, my issue has been that both "shelves" do the same/similar thing which is pop out a sidebar, so i think they should be named consistent.
Here's 2 options:
Toolbar, Propsbar. short, consistent naming
Toolshelf, Propsshelf.. does not work...
Going right out there would be:
SideTools, SideProps.
The use of Props, improves the distinction between the properties areas.
Thanks.
Really hopeful this gets solved.

Propsbar sounds odd to me, but prop-shelf is great. Also fine with properties sidebar, but propshelf is my new favourite :)

Brecht Van Lommel (brecht) closed this task as Resolved.

Resolved in 2.8 by naming it "sidebar".