Page MenuHome

Triangle primitive breaks hair info "Intercept" usage
Closed, ArchivedPublic

Description

System Information
Win 7 x64

Blender Version
Broken in build on Feb 10, 2015 (hash displays as Unknown)

Short description of error
Using the Hair Info > Intercept node to control shader effects along a strand is broken when the primitive is set to Triangle. Works as expected with Curves and Line Segments

Exact steps for others to reproduce the error

Open .blend, switch between the different hair primitives.

Details

Type
Bug

Event Timeline

Matt Heimlich (m9105826) set Type to Bug.
Matt Heimlich (m9105826) created this task.
Matt Heimlich (m9105826) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Normal priority.Feb 11 2015, 9:06 AM

I don't really think it was intended to work, this information get's lost when triangulating the hair. Maybe we could store some attributes on triangulation, but would need to check on code more closely.

Sergey Sharybin (sergey) closed this task as Archived.Feb 20 2015, 1:36 PM

Checked the code. Current implementation of Intercept information indeed implies it's coming from curve, not triangles. It's probably possible to extend it to triangles, but i wouldn't consider this a bug.

Moving to the TODO now: http://wiki.blender.org/index.php/Dev:2.6/Source/Render/Cycles/ToDo#Smaller_Features Thanks for the report anyway!