Page MenuHome

No alpha blend in cycles viewport, should expose BGE alpha blend setting in cycles UI.
Closed, ArchivedPublic

Description

System Information
Ubuntu 14.10 - GeForce 840M

Blender Version
Broken: 2.73a, master

Short description of error
No alpha blend in cycles viewport, should expose BGE alpha blend setting in cycles UI, since it affects cycles too, and its the only way to set the blend mode in cycles viewport.

Exact steps for others to reproduce the error
Just open the file, the plane texture doesn't show alpha


Go to Blender Game, and change the alpha blend setting from opaque to alpha blend.

If you go back to Cycles, the texture is displayed correctly.

Details

Type
Bug

Event Timeline

David Gascueña (netich) updated the task description. (Show Details)EditedFeb 27 2015, 3:50 PM
David Gascueña (netich) set Type to Bug.
David Gascueña (netich) created this task.
David Gascueña (netich) raised the priority of this task from to Needs Triage by Developer.

Forgot the blend file

You are right.
But you forgot to pack texture.

yes sorry, now it's packed

by the way, I discover this looking to "image as planes" add-on, because it uses this 'hack' to show the textures with transparency

Julian Eisel (Severin) triaged this task as Confirmed, Medium priority.

Can confirm that. @Antony Riakiotakis (psy-fi), Maybe something stupid like a GL_DISABLE is missing or so? But looks like the root of the bug comes from the game engine -> moved to Game Engine

I don't think it should be tagged as BGE. Other than my personal interest, as it affects my workflow with 2.5D interfaces and characters, It is a problem with cycles, whose workaround is a setting in the BGE. It should be exposed in cycles, since it affects its viewport.

The issue here is that changing a setting in the Game Engine has influences on Cycles what should never happen (my guess is an incorrectly set OGL context). Having an viewport transparency option for cycles would be a todo which again would mean we had to close the bug report as "Invalid".
So for me this seems to be a BGE issue and I'll keep this opinion until a developer who is more familiar with these areas says something different ;)

I checked into the code and I hate to agree with Julian indeed, this is a game engine option that ended up influencing cycles by careless coding. The bug is that this even influences cycles in the first place. We can be smarter here and detect transparency by presence of a transparent BSDF in the node tree.

Generally, all this influence of game engine options to our regular material pipeline is really crappy and has to be fixed at some point.

well, at least the bug serves well as a workaround, I shouldn't have filed the bug :). Anyway, I'm glad the viewport is going to get some love, now that Mike Erwin is on the boat too. Now, options that affect viewport, are all spread across the UI. Good luck!

Antony Riakiotakis (psy-fi) lowered the priority of this task from Confirmed, Medium to Confirmed, Low.Mar 11 2015, 3:35 PM

We will check that after release

Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 2:15 AM
Aaron Carlisle (Blendify) claimed this task.

This task is being closed because the BGE has been removed in Blender 2.8.