Page MenuHome

Blender Crashed by Joystick.
Closed, ResolvedPublic

Description

System Information
Windows 8.1, Intel Gen4

Blender Version
Broken: Blender 2.73a and nightly.
Worked: Blender 2.72b official.

When joystick are used in logic brick, press 'p'. Blender crash!.

Event Timeline

AFAIK this issue is fixed already, could you test using our latest build from buildbot?

Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mar 3 2015, 10:24 PM
Julian Eisel (Severin) edited projects, added Game Engine; removed BF Blender.

Another test..

.. for 2.73a, buildbot: blender-2.73-1965623-win64 and cmake.

  1. Creative Cobra3D force feedback - result: crash
  2. Logitech Extreme 3D - result: runs once (after 'p'), exit p, and run 'p', result: no response for joystick. keyboard, ok. No crash.

..for 2.72b. Everthing is ok.

On my machine (Win7 64-bit, Blender 2.73a, Logitech Force 3D Pro joystick) I can't reproduce the issue; everything works fine. Please attach a blend file that demonstrates the issue.

  1. Test file.. press 'p'.. up/down. 'esc', press 'p' again.. jostick won't work anymore. (Logitech 3D Pro)
  2. Creative Cobra - Blender crash.
  3. Does BGE implement joystick slider?

https://www.dropbox.com/s/611weq3fh6xjwpq/joyTest.blend?dl=0

Jorge Bernal (lordloki) closed this task as Resolved.Mar 7 2015, 9:31 PM
Jorge Bernal (lordloki) claimed this task.

Closed by commit b4fccce.

Thanks for reporting