Page MenuHome

Unable to copy/paste nodes between instances
Closed, InvalidPublic

Description

System Information
Kubuntu Linux 14.04
nVidia GT430: VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
nvidia driver 340.65

Blender Version
Broken: 2.73a , 2.73.9 (2.74 testbuild)

Short description of error
Related discussion:
http://www.blenderartists.org/forum/showthread.php?364234-Copy-paste-Nodes-from-one-project-to-another-with-Ctrl-C-and-Ctrl-V

Is not possible to copy nodes from one instance to another instance. Blender uses the clipboard only if you copy/paste into the same instance of Blender. If you copy in an Blender instance and then paste into another Blender instance, then this second instance reports that the clipboard is empty or clipboard nodes are an incompatible type depending of the clipboard contents.

Exact steps for others to reproduce the error
Open one .blend project in one Blender instance. Open other .blend in another Blender instance. Select nodes o node groups (Shader or Compositing) in the first instance and press Ctrl+C to copy them to clipboard. In the second Blender instance put the mouse pointer over the node editor and press Ctrl+V to paste copied nodes from clipboard. Blender report "Error - Clipboard is empty" or "Cipboard nodes are an incompatible type" depending of the clipboard contents.

Details

Type
Bug

Event Timeline

YAFU (YAFU) updated the task description. (Show Details)Mar 6 2015, 2:05 PM
YAFU (YAFU) added a project: BF Blender.
YAFU (YAFU) set Type to Bug.
YAFU (YAFU) added a subscriber: YAFU (YAFU).
YAFU (YAFU) created this task.
YAFU (YAFU) raised the priority of this task from to Needs Triage by Developer.
Julian Eisel (Severin) closed this task as Invalid.EditedMar 6 2015, 2:58 PM
Julian Eisel (Severin) claimed this task.

Hi @YAFU (YAFU), right away, this isn't a bug, this just isn't supported technically. After having a quick look at the code, I think copying an object stores data on the hard drive so that it's accessible from another instance of Blender. Copying nodes uses a completely different - internal - technique, so AFAIK it's not really possible to access this from an external program. The same applies to masks and tracking markers btw.

So thanks for the report, but as I said that's not a bug, it's a limitation.

Ok, I understand.
Just clarify that I was not looking for technical support in this report. I understand this is not for that. Best explained in the above thread.
Regards.