Page MenuHome

Color piker missing
Closed, InvalidPublic

Description

System Information
Operating system and graphics card

win 7 64 550ti

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen) 5737832
Worked: (optional)

Short description of error
color piker missing
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Color picker missing in the uv image when adding a new image. check the image below

Details

Type
Bug

Event Timeline

Erick Tukuniata (erickblender) raised the priority of this task from to Needs Triage by Developer.
Erick Tukuniata (erickblender) updated the task description. (Show Details)
Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mar 9 2015, 12:40 PM

What do you mean by missing? Does it also not show up if you turn up the brightness value at the right?

@Julian Eisel (Severin), he's talking about the eyedropper. As far as I know it's only available when painting, then I don't know what the rule is for that one.


In fact, it is not available only for painting. It is available for any color slot in UI (material colors. color ramps, etc...) except, here.

Not a high priority problem. Just consistency remark.
Maybe psy-fi want to force users to use Fill brush while painting. :)

Sorry for wrong name it actually eye drop missing, thanks guy for helping ;)

OK !
To clarify, problem is not relative to UV/Image Editor. It is specific to image creation.
We can create image from buttons on toolself of 3D view, Texture tab of Properties Editor, Image node, etc...

Each time, it is same color picker panel with missing eye dropper.

Might easily be a todo, but need to investigate first.

Julian Eisel (Severin) closed this task as Invalid.EditedMar 13 2015, 12:53 AM

Had a look at the code but this was disabled intentionally. There is a comment saying:

/* if color block is invoked from a popup we wouldn't be able to set color properly
 * this is because color picker will close popups first and then will try to figure
 * out active button RNA, and of course it'll fail
 */

So the eyedropper is disabled for color buttons inside popups as it doesn't work properly.
Also see: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/UserInterface#UI_Widgets, T32396

Anyway, thanks for the report, but this is considered as a todo.