Page MenuHome

Tablet mouse forced into pen (absolute) mode
Closed, ArchivedPublic

Description

Blender version: 2.74 RC
Tablet model: Wacom Intuos3 9x12
Tablet driver version: 6.3.11-4

While any of Blender's windows are active, the Intuos mouse is forced into pen mode. This happens as soon as any window is activated (but does not remain once another application is activated), making it difficult even to click on the window header as the cursor is repositioned on mouse-down.

To reproduce, open Blender and use a tablet mouse to navigate the interface. The mouse should operate as if it were the tablet's pen.

Details

Type
Bug

Event Timeline

RSchr (rookie1024) added a project: BF Blender.
RSchr (rookie1024) set Type to Bug.
RSchr (rookie1024) created this task.
RSchr (rookie1024) raised the priority of this task from to Needs Triage by Developer.
Julian Eisel (Severin) closed this task as Archived.Mar 19 2015, 12:49 AM
Julian Eisel (Severin) claimed this task.

Hey @RSchr (rookie1024),
unfortunately we currently don't have a way to differentiate between an event from a tablet and an event from an Intuos mouse. Shortly said, tablet mice are currently not supported :/

Anyway, thanks for the report!

RSchr (rookie1024) added a comment.EditedMar 21 2015, 11:41 PM

I looked through Wintab's documentation, and it would appear to have some support for detecting the pointing device: Wintab FAQ

However, considering that Blender is cross-platform I understand this would have to be implemented as natives for each platform.

Another thing I noticed was that even the pen is forced into absolute mode in Blender, even when set to relative (mouse) mode. Couldn't find anything that allows you to find the current mapping mode, so I guess that's kinda unfixable.

Mac appears to be able to do it, too: http://www.wacomeng.com/mac/Developers%20Guide.htm

Linux looks like it could be a problem, though. (Of course, that's because using a tablet with Linux already is a problem)