Page MenuHome

AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
Closed, ArchivedPublic

Description

System Information
Windows 8.1 and (AMD A10-7800) Radeon R7, 12 Compute Cores 4C+8G 3.50GHz

2.74 windows 64
Broken: (AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead)
Worked: (optional)

I recently downloaded the latest version and when i started it, i got this error.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

tibo van gindertaelen (CoreX) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.

Sounds like this isn't really a bug, if OpenAL can't get the frequency it requests it just uses a fallback value.

Apart from this message are there any observable errors?

This can be read as a warning from blender's perspective as I see it. At least in virtual machine (kvm) + windows 7 this also happens to me but sound seems to work there.

Julian Eisel (Severin) closed this task as Archived.Apr 13 2015, 6:27 PM
Julian Eisel (Severin) claimed this task.

Sounds to me like this could be closed (no response so far). Not sure if this should be added to the todo as it seems to be an intentionally added fallback method?

no nothing, no other errors just this one :s

i tried reinstalling old versions but it didnt work...
A strange thing is that it actually worked yesterday but it freezed after 5 mins and closed..
Sorry i didn't respond, my pc had to move away during my exams