Page MenuHome

blender segfaults on startup with my startup.blend
Closed, InvalidPublic

Description

System Information
FreeBSD 10.1 amd64 GT520

Blender Version
Broken: rB98f41066943d8b1cf9236d6b358d1e84c9e7cc4b
Worked: master about a week ago.

Short description of error
Blender segfaults on startup if my startup.blend is in place. After moving it there is no problem, I can then manually load the file ok. Re-saving it as startup file doesn't fix the issue.

Exact steps for others to reproduce the error
Line 377 in source/blender/windowmanager/intern/wm_window.c is the culprit -

if (win->stereo3d_format->display_mode == S3D_DISPLAY_PAGEFLIP)

I see ok values for win but win->stereo3d_format is always 0

Details

Type
Bug

Event Timeline

Shane Ambler (sambler) set Type to Bug.
Shane Ambler (sambler) created this task.
Shane Ambler (sambler) raised the priority of this task from to Needs Triage by Developer.
Dalai Felinto (dfelinto) closed this task as Resolved.Apr 8 2015, 5:31 PM

The file you attached has version 274, and subversion 4. It seems that you saved it between the multiview commit, and the subsequent commit (that fixed doversion/backward compatibility).

I opened your file and forced the doversion code, it should now work for you:

I'll close it now, but let me know if the issue is not fixed.

Dalai Felinto (dfelinto) changed the task status from Resolved to Invalid.Apr 8 2015, 5:32 PM
Dalai Felinto (dfelinto) triaged this task as Confirmed, Medium priority.