Page MenuHome

Blender starts up console then immediately closes.
Closed, InvalidPublic

Description

System Information
Windows 7
Nvidia GeForce GT 630M

Blender Version
Broken: 2.74 (Can't get to splash screen)
Worked: 2.73?

When I click on the Blender icon, it opens up console, then says this error.

AL lib: <EE> UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
Error: EXCEPTION_ACCESS_VIOLATION
Writing: C:\Users\Bleghfuric\AppData\Local\Temp\blender.crash.txt

Then, the console just closes. A copy of the blender.crash.txt file is

__

I do not know how this error occurs, but it consistently happens when I run Blender.

Details

Type
Bug

Event Timeline

Josh (Bleghfuric) added a project: BF Blender.
Josh (Bleghfuric) set Type to Bug.
Josh (Bleghfuric) created this task.
Josh (Bleghfuric) claimed this task.
Josh (Bleghfuric) raised the priority of this task from to Needs Triage by Developer.
Josh (Bleghfuric) removed Josh (Bleghfuric) as the assignee of this task.

Hi, DL opengl32.dll for your system and copy it to your Blender directory where blender.exe resist.
This start Blender in software OpenGL mode and bypasses the hardware accelerated mode.

ftp://ftp.blender.org/sergey/softwaregl/

If Blender run it is a driver or update problem.
Make sure your system is fully updated, Service Pack 1 and driver from Nvidia.
The GPU driver from Microsoft are often not up to date.

Cheers, mib

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please:

  • Ensure both your OS and drivers are fully up-to-date.
  • For Windows 7, at least service pack 1 is mandatory, please ensure it is installed on your machine.
  • Ensure your GPU driver supports at least OpenGL 1.4.
  • Ensure you have installed MSVC2013 redistributable package (http://www.microsoft.com/en-us/download/details.aspx?id=40784).
  • Try to disable any running antivirus.
  • Ensure you have no python executable available in your %path% envvar.
  • Try to re-download and re-install Blender.
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to place this dll next to your blender.exe (software OGL, will be slow, but will show whether this is a driver issue or not).

no news in a week sorry but we have to close this to keep the bug tracker clean.

Aaron Carlisle (Blendify) claimed this task.

I am also affected by this bug, so it's still around and appears to be a pretty bad issue, considering I can't run Blender. I was running Blender 2.69 just fine this morning, then this afternoon I updated to 2.76rc3, the latest version. Blender now crashes on startup with only the message "Error: EXCEPTION_ACCESS_VIOLATION". No crash log is created in the location OP specified.

Addressing most of your bullet points Bastien:

  • I recently updated my graphics card driver (about a week ago) so I think it's safe to assume my OS and drivers are up to date. I'm running Windows 10.
  • My GPU driver supports OpenGL 1.4, since I was using Blender this morning and use OpenGL 2+ for other things regularly.
  • MSVC 2013 Redistributable (x86) is listed in Programs and Features, so I have it installed.
  • Only using Windows Defender, no other antivirus and no issues previously with this.
  • No Python exe is listed in %path%.
  • I ran the installer again and selected "Repair," but nothing changed.
  • I started Blender with factory settings using --factory-startup and got the same result.
  • I placed your opengl32.dll next to blender.exe, but got the same error.

Basic system specs:

  • Windows 10 Pro x64
  • AMD Radeon R9 200 / HD 7900 series (x2, no crossfire)
  • Graphics driver date 8/21/2015

Let me know if there is more information I can provide. For now I think I'll go back to an earlier version of Blender.

Edit:
Just to update, I made a backup of my 2.76rc3 installation for testing, deleted the original, and installed 2.73 since OP said 2.73 worked. Version 2.73 also works for me.

I was also experiencing this bug on with version 2.76 windows 10 like Will Tice. Like Will I had followed all the instructions above to no avail. I decided to try the older 2.73 version of blender and was uninstalling 2.76 when I noticed there were left over files from version 2.69 from windows 8. After thoroughly cleaning out all blender files and reinstalling 2.76 I'm having no issues. Checking for and removing previous versions of blender may help with this issue.

I can confirm what Graham Pitcher said. I had the same problem but noticed I had a 32bit 2.6x version around together with the 2.76 I had just installed. Getting rid of the two of them and reinstalling just the 64bit 2.76 got rid of the problem.

I'm using Windows 10 and had this issue. Uninstalling both versions of blender and reinstalling blender-2.76b-windows64.msi fixed it. Here's the error:

C:\Program Files\Blender Foundation\Blender>blender.exe
Error: EXCEPTION_ACCESS_VIOLATION

Error: EXCEPTION_ACCESS_VIOLATION
I am getting this exception. This is happening when I try to open blender model model files .blend file.

I placed the opengl32.dll in the same directory as blender.exe

The problem did not get resolved. Any other ideas, Please?

Please create a new bug report.