Baking Normals with Bevel modifier with limitation bakes bevels that should not be there
Closed, ArchivedPublic

Description

System Information
OSX 10.10.3 NVIDIA GeForce GTX 680MX 2048 MB
Blender Version
Broken: 2.74
Worked: (optional)

Short description of error
As in the Title, if you have a bevel modify with angle limitation it bakes as if there is no limitation set.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Load the attached, select CudeHD then shift select Cube, got the Bake panel and bake. You can see in the attached screenshots bevels have been baked on the flat face even though they should not be there

Details

Type
Bug
Andrei Nadin (AnadinX) updated the task description. (Show Details)
Andrei Nadin (AnadinX) raised the priority of this task from to Needs Triage.
Andrei Nadin (AnadinX) set Type to Bug.

On more playing its not really anything to do with limits, just seems to be baking bevels into those extra diagonal edges even if I apply the bevel

Can confirm the issue… Sergey, Dalai, maybe you have idea about what's happening here?

Bastien Montagne (mont29) triaged this task as Normal priority.Apr 10 2015, 4:36 PM

Issue here as I see it, is that the low poly has edge split modifier, and any time you have split edges and bake normal map (without cage) you need to allow the split faces space in the UV layout, so split edges really need to have seams, and be packed with a margin. Else you do get the overlap where normal data is missing giving the appearance of a "bevel" where there actually isn't one.. that is to say wherever there is a hard edge (split) there needs to be a seam.

Also the normals of the high poly are inverted for whatever reason. so that's why you get the "bad" yellow colour - the normal map should be mostly blue.

Sergey Sharybin (sergey) closed this task as Archived.May 25 2015, 9:18 PM
Sergey Sharybin (sergey) claimed this task.

Think @Olson Burry (olson) covered it all and i don't really see bugs here.. So thanks for the report but archiving it for until some real bug is discovered.