Page MenuHome

Rigid Body not works well with curve modifier
Closed, ArchivedPublic

Description

Blender Version
2.74

Short description of error
watch the cube not moving together with conveyor, cube should moving in direction same as conveyor moves. this is the result of using curve modifier, Do you have any idea how to make cube moves same direction of conveyor ?.

Exact steps for others to reproduce the error

play animation

Details

Type
Bug

Event Timeline

yellow foxz (yellowfoxz) raised the priority of this task from to Needs Triage by Developer.
yellow foxz (yellowfoxz) updated the task description. (Show Details)
yellow foxz (yellowfoxz) set Type to Bug.

Assigning to @Sergej Reich (sergof) to get his input. Do you think that's a bug, Sergej?

Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Normal.Apr 13 2015, 10:13 PM

same as this one , how to solve this problem, box should falls by gravity at the end of conveyor .

There are two things here:
If you want the rigid body to deform, you have to check the "Deforming" checkbox.
The second problem is that you actually move the deforming rigid body, so even if it looks like it's standing still to the simulation the object is moving in the direction it's animated (I understand that that's what you need to do for the curve deformation to work). So the second file will work, but the circle will still fail.

It should be possible to fix this, but currently it's a limitation.

Julian Eisel (Severin) closed this task as Archived.Apr 14 2015, 3:40 PM

Closing as todo then.

Thanks for the report nevertheless @yellow foxz (yellowfoxz) :)