Page MenuHome

Blender crashes when rendering (with render_auto_save.py addon)
Closed, ArchivedPublic

Description

System Information
OS: windows 8.1 64bit
GPU: nvidia gtx 860m

Blender Version
Broken: 2.74.5

Short description of error
when rendering a animation with the "render_auto_save.py" addon


Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

heres a blend file that causes the crash

  1. open blend file
  2. enable the autosave option from the Render_auto_save.py addon
  3. render animation
  4. see blender crash:(
# Blender 2.74 (sub 5), Commit date: 2015-04-28 20:08, Hash f9d23b8

# backtrace
19: BLI_system_backtrace - 0xAF4ABA30
18: blender_crash_handler_backtrace - 0xAE286960
17: blender_crash_handler - 0xAE2869B0
16: windows_exception_handler - 0xAE286C30
15: UnhandledExceptionFilter - 0x6C311AD0
14: memset - 0x6F0A5140
13: _C_specific_handler - 0x6F092800
12: _chkstk - 0x6F0A3E70
11: RtlRaiseException - 0x6F063920
10: KiUserExceptionDispatcher - 0x6F0A3060
9: mesh_build_data - 0xAEFA1FA0
8: makeDerivedMesh - 0xAEF99400
7: BKE_object_handle_update_ex - 0xAEF3AB70
6: scene_update_object_func - 0xAEE51AA0
5: task_scheduler_thread_run - 0xAF5074A0
4: sched_get_priority_max - 0x63CD12FD
3: sched_get_priority_max - 0x63CD12FD
2: sched_get_priority_max - 0x63CD12FD
1: BaseThreadInitThunk - 0x6CA913B0
0: RtlUserThreadStart - 0x6F025410

Details

Type
Bug

Event Timeline

dan grauer (kromar) set Type to Bug.
dan grauer (kromar) created this task.
dan grauer (kromar) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.
Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, Medium.

I can confirm the issue, and it doesn't crash for me when enabling "Lock interface during rendering". I guess the root cause is really the long standing thread safety issue for which this option was added, and the auto save happens to be triggering the issue by causing a redraw of the 3D view.

I succeeded when I rendered it after returning frame to 1.
A log file when I succeeded.


But an attribute error is recorded last.

A log file when blender crashed.


EXCEPTION_ACCESS_VIOLATION is recorded.

version 2.74 (sub 5), branch b'master', commit date b'2015-05-10' b'23:27', hash b'9e2e85a', b'Release'

You set UV/Image Editor in Paint mode.
If you change it to View mode, it may not crash.

Sergey Sharybin (sergey) closed this task as Archived.May 25 2015, 2:30 PM

This is indeed a conflict between viewport and render threads, the addon just increases probability of issue to happen.

Solving this issue is a part of copy-on-write proposal which will happen after new depsgraph is replaced current one.

So thanks for the report, but closing for now. Use locked interface meanwhile is the recommended way to go.