Page MenuHome

proportional editing issue with huge clip view
Closed, InvalidPublic

Description

Proportional editing is not applied on the first click when you have a huge clip view in your 3d view.
You have to use the mouse to change the size of the influence a little bit, then the proportional editing gets applied.

You can test with the following settings :
clip start : 1000
clip end : 1000000
object dimension X : 15000
object dimension Y : 16000
object dimension z : 1700

Thanks

F.

Event Timeline

I forgot to mention that I'm talking about the Edit Mode (moving vertices, edeges,...)

Antonis Ryakiotakis (psy-fi) lowered the priority of this task from 90 to 30.May 28 2015, 12:47 PM

Please attach an example blend file.

Here it is :
1 - Go to edit mode
2 - Select a vertex
3 - Grow the proportional editing influence so it takes more than one vertex
4 - Deselect your vertex
5 - Reselect the vertex
6 - translate

  • only the selected vertex moves

7 - change the proportional editing influence by 1 step (mouse wheel)

  • all vertices moves.

Can't reproduce this here. You do not specify which version of blender has the issue or any OS/GPU information in your report. Can you add these? Can you also try a build from https://builder.blender.org/download/ for your platform and see if the issue persists?

Keeping report incomplete until all requested info is provided.

sorry about all this, I tried we a build from buildbot, and it seems to work. We will double check our version then. I'll make more test next time.

Thanks

F.

francoisgfx (francoistarlier) changed the task status from Unknown Status to Invalid.Jun 1 2015, 2:26 PM