Page MenuHome

CTRL+backspace doesn't take into account underscores _
Closed, InvalidPublic

Description

System Information
Win 7 64bit,
Fedora 21 64bit,
mobility radeon 5650

Blender Version
Broken: Official 2.74 release (and earlier I believe)

Short description of error
CTRL+backspace doesn't take into account underscores _ when erasing strings in text fields.

Exact steps for others to reproduce the error
Have object_name_01 in a text field and press ctrl+backspace. The whole string gets erased.

If you have object.name.01 or object:name:01 or object-name-01 ctrl+backspace erases only until it gets to the special character i.e.

object.name.01
object.name.
object.

The expected behavior would be to take underscore into account as well.

Details

Type
Bug

Event Timeline

Matjaž Lamut (lamoot) set Type to Bug.
Matjaž Lamut (lamoot) created this task.
Matjaž Lamut (lamoot) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but there is no bug here, it's working as intended (breaking on python delimiters). Note that that kind of feature can be handled in many different ways, all IDEs I know off have different breaking chars sets, there is no ideal choice.

Ok, thanks for the explanation, I wasn't aware of the underlying intention for delimiters. It interferes in small way with my workflow, but I guess changing this would only switch the problem to another group of users, and not actually solve it.