Page MenuHome

Fake absortion cycles method doesn´t work anymore. Seems to be some problem with the input Lighpath node
Closed, InvalidPublic

Description

System Information
Windows 7 Nvida GTX 580
Blender Version
b53836d
Short description of error

There´s a method to fake absortion, explained by Gottfired Hoffman and used on lot of node setups which I have try to reproduce and I just can´t make work. Just load the file:

http://www.pasteall.org/blend/36380

It´s a pretty simple node setup tested in many cases for glass material. The thickest parts of the mesh should be darkened. Buth nothing happens. The problem seems to be related with the Backfacing from Geometry input or the Ray Length from the Light Path node. When connnected to the viewer of the Node Wrangler addon the display pure black and pure white, which doesn´t make too much sense for me.

Details

Type
Bug

Event Timeline

This the snapshote in order to save time to developers.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jun 3 2015, 5:53 PM

Which blender version it worked and when it stopped working? Is it only visible when using node wrangler addon or also happens with final renders?

It also happens with final renders and preview renders. It also happens on 2.75 Test build. We are talking about Win7 32 bits. I´ll try it on OSX to see if this happens also.

I really don´t know on which version this failed.

It seems to be broken on 2.73 also

Thomas Dinges (dingto) closed this task as Invalid.EditedJun 4 2015, 7:34 PM

The blend file from Gottfried still looks correct in current master http://blenderdiplom.com/files/blenderdiplom.absorption.zip for me.

Differences: In Gottfrieds file, the Absorption color is in the first input, and the base color in the second. In other words, swap the 2 colors and it works... And the first node in the original setup does a multiply, not an add.