Page MenuHome

Long image loading
Closed, ArchivedPublic

Description

System Information
W8 x64, GTX 980

Blender Version
Broken: 2.74

Short description of error
After I select image file to be as a background (png, 1280*720) and press Open, Blender does not respond nearly 5 seconds.
It happens with almost every file I select

Details

Type
Bug

Event Timeline

Maxim Tkachenko (maleficmax) created this task.
Maxim Tkachenko (maleficmax) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please:

  • Attach here one of your .png giving you issues!
  • Ensure both your OS and drivers are fully up-to-date.
  • Ensure your GPU driver supports at least OpenGL 1.4.
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak OGL settings in UserPreferences, System tab.
  • Attach here the report generated by Help -> System Info.

Here it is

My system is up-to-date and it supports OpenGL 1.4 (gtx 980, man)
For some reason I can not reproduce it now, but periodically I have this freezes when loading even small images. It can happen several times a day.
It happens on my working PC and my home one's.
My working pc system info is here:

How much RAM do you have? How much is used when you get those slow downs? (In other words, aren’t you swapping?).

Also, do you use an antivirus, and if so, can you try disabling it?

I have 32 gb RAM :) I hope, I am not swapping)
And yes, i have McAfee, but can not disable it - do not have an admin privileges.

I confirm that loading an image anywhere into Blender can take around 5 seconds, the strange thing is that an image that's only a handful of kilobytes in size takes the same amount of time as one 16 megabytes in size.

Though this is only on loading the first image, subsequent images load a lot faster. It may also disappear once the asset engine project is committed because I recall reading about optimizations there (which you should know). This is regarding the loading of images into the UV editor by the way.

i can also confirm this, never had the courage to report it as it's not really a bug, only a very unoptimized part of the code.

I cannot confirm it.
It is immediately displayed on the background image and Image Editor.

Did you test on Windows Perfection cat? the bug report is about windows. (8 but in my case it also happens on 7)

Tested this a bit more:

  • it happens with factory settings for sure so it's not addon-related
  • it seems to only happen when "file"->"external data"->"automaticaly pack into .blend" is activated.
  • The file has to be saved at least once with one image to make it happen.

Investigating more....

ok, so it's easy:

  • save default scene
  • reload it
  • open a .jpg and it takes 5sec.

Without saving it's opened instantly

and you saved and reloaded your scene before testing ? it only happens on saved files.

I tried this in the following procedures.

I load an image as Background Image.
I store an image loaded in Image Editor.
I unlink this image in Image Editor.
I unlink this image in Background Image.
I load an image as Background Image.

Cant redo the error (64bit Linux, with/without auto-pack-images)

I tried this in the following procedures.
I load an image as Background Image.
I store an image loaded in Image Editor.
I unlink this image in Image Editor.
I unlink this image in Background Image.
I load an image as Background Image.

Well you have to make "file" -> "save as" first, the bu only appear when the blend (not the image) is saved. In my test, it only happens with .jpg on windows 7.

I tried this in the following procedures.

factory settings.
I load an image as Background Image(.jpg or .png).
"file"->"external data"->"automaticaly pack into .blend"
save blend file.
reload it.
open a .jpg or .png.

I cannot confirm it.

okay, nailed the bug :D
-the blend file has to be saved on same drive as image to be loaded
-relative path has to be ticked while loading image (that's why same drive, otherwise it's absolute path)
Finally ! (compression and packed images are not required)

please test again with new steps to confirm on other systems

I could reproduce it on several different configuration so... any news on that one ?

Julian Eisel (Severin) closed this task as Archived.Jun 17 2015, 10:19 AM
Julian Eisel (Severin) claimed this task.