Page MenuHome

Hair objects instance with height along the y-axis
Closed, ArchivedPublic

Description

It appears that hair folicles need to be rotated to have the mesh's content use the y-axis as the height as they are instanced with a rotation as such.

  1. Is it on the roadmap to fix this?
  2. Has the community of blender accepted and commited to this workflow for asset creation? If so, for what reasons?

It seems completely absurd to force the production of meshes that can only be used exclusively with the particle system as:

  1. the height rotation transformation has to be applied to the mesh to facilitate correct hair rotation.
  2. hair objects do not support nested dupligroups

In combination with this (https://developer.blender.org/T44963) this appears to be a completely nonsensical pipeline (ie single mesh hair folicles that are rotated with height as the y-axis):

All Blender versions as far as I know.

Details

Type
Bug

Event Timeline

Diet Coke (dlots) added a project: BF Blender.
Diet Coke (dlots) set Type to Bug.
Diet Coke (dlots) created this task.
Diet Coke (dlots) raised the priority of this task from to Needs Triage by Developer.

Well, I don't know for the other user, but yes, it's one of those "workflow"/workaround we learned to live with. I'll be happy to live without it. Now that the hair system is a completely new and independent part, maybe it could be possible? For compatibility, I guess it's pretty straight forward to do (use old convention if file saved with <2.7x and new conv if >2.7x with some possibilities to convert)? Campbell is doing a lot of consistency and fixing work at the moment, so maybe if he goes through the hair system we could have a chance.

Blender 2.4X had top view as default.
Actually, object creation have as default World, Global coordinates for object axis.

In both cases, it means that a plane object would be in XY plane. With this creation workflow in mind, you don't have to rotate your mesh while creation.

Now, it is more common to use 3D meshes with thickness . But some years ago, most of dupli use with particles were transparent planes or thin low poly meshes to simulate grass or feathers of a bird.

Most of 2.4x ressources were using this workflow. When a try was made to jump to z axis as height for 2.5, every user trying to use these ressources was filling a bugreport about particles rotation.
A change like that will break most of ressources and implies to update rare documentation ressources about particles as well.
So, it implies a big warning in release log or a thread on blenderartists.
If you take into account that blender release cycles is very short; it is probably something to change at start of a new serie.

well, we can have both (z as normal and y as normal) with an automatic check of the version used to save older files to put the right settings. The hair code was just completely rewritten, making it better now should be easier. And 2.7x was meant to remove some old legacies and allow some small forward compatibility breakage (z as normal will not function in previous version but backward compatibility will be ok).

Antony Riakiotakis (psy-fi) closed this task as Archived.
Antony Riakiotakis (psy-fi) claimed this task.

Yes, it's irritating but it's not a bug. Might be changed when particles get rewritten. Since the tracker is for bugs, not redesign and longer term todo, will close now.