Page MenuHome

Blender 2.75 RC1 Crash on startup (win 64bit )
Closed, ArchivedPublic

Description

well it crashed straight on start, after some restarts i managed to get the text of the command screen

Color management: using fallback mode for management
BLF_lang_init: 'locale' data path for translations not found, continuing
AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
Warning! bundled python not found and is expected on this platform. (if you bui
t with CMake: 'install' target may have not been built)
Fatal Python error: Py_Initialize: unable to load the file system codec
ImportError: No module named 'encodings'

Details

Type
Bug

Event Timeline

Peter Boos (PGTART) set Type to Bug.
Peter Boos (PGTART) created this task.
Peter Boos (PGTART) raised the priority of this task from to Needs Triage by Developer.

additional info, the python exe doesnt work either
error

Fatal Python error:Py_Initialize: unable to load the file system codec
ImporterError: No module name 'encodings'.

System windows 7, octocore GPU Nvidea GforceGT, 24Gig mem

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Looks like something went wrong in installation, suggest you try to re-download and install blender again. Also, please:

  • Give us your exact OS and GPU versions, as requested in the template!
  • Ensure both your OS and drivers are fully up-to-date.
  • For Windows 7, at least service pack 1 is mandatory, please ensure it is installed on your machine.
  • Ensure your GPU driver supports at least OpenGL 1.4.
  • Ensure you have installed MSVC2013 redistributable package (http://www.microsoft.com/en-us/download/details.aspx?id=40784).
  • Try to disable any running antivirus.
  • Ensure you have no python executable available in your %path% envvar.

the error "AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead"
it's already present in previous 2.74 release, but I have no real issue about (perhaps also because I don't use sound, and this seem related to sound, isn't?)

Peter Boos (PGTART) added a comment.EditedJun 12 2015, 11:10 PM

i'm able to run 2.74

GPU model Nvidea 630M

Win 7 SP1, and all updates as of writing today, i keep my system in health...

no python in path variable (would be strange anyway if that was wrong)

There doesnt popup a template when one fills in a bug request ! (using firefox latest)

Antivirus has blender path excluded

All drivers are up to date, it doesnt seam to relate to GPU / drivers etc, but rather to something PYTHON, the audiolib info warning just checked also happened in 2.74; so i doubt thats the cause..

wasnt this the version that had python differently included, and might it have gone wrong there ?

This happened to me with the gooseberry build a week ago after a couple of new builds it fixed itself

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

@Peter Boos (PGTART) yes, this is a python issue, and yes, python distribution/packaging has changed in 2.75 (we now also include python executable itself, so that scripts which want to run parallel tasks with several processes do not launch a full blender each time).

Have you been using the installer version, or the zip install-free archive?

@Martijn Berger (juicyfruit) you may have more/better ideas about the issue here?

Ok its resolved here.

I think something was wrong with the zip file, i downloaded it again, seams to work now.

Bastien Montagne (mont29) closed this task as Archived.Jun 13 2015, 7:00 PM
Bastien Montagne (mont29) claimed this task.

Ok… Well, closing for now then, thanks for the head up. :)