Page MenuHome

OpenGL, Dupli-Objects draw without shading.
Closed, ArchivedPublic

Description

This report is the same error exposed in T45117 but in this case its not a regression (Happens in 2.73 as well).

Open the attached file, and notice how the circled object becomes flat-shaded-grey on redraw.

(apparently only happens with NVidia drivers, see T45117 for details).


Looked into this further, Turns out this is caused by calling glDrawElements inside a display list (glNewList / glEndList),

So this might have to be moved into OpenGL-Errors.

Details

Type
OpenGL Error

Event Timeline

Generally, I've found in an older similar report that the driver does not like setting up buffers and not using them. So if we can avoid that we can probably solve the problem.

More info, looks like the driver messes up when compiling the display list. If we add GPU_normal_setup in loose edge drawing, the error goes away. However I am intrigued because error does not happen in 939948c

I opened a ticket with NVIDIA, not sure if they'll respond (unfortunately needs login to access)

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.
Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 3:22 AM
Aaron Carlisle (Blendify) claimed this task.