Page MenuHome

Rendering causes Blender to Crash when Motion Blur is turned on...
Closed, InvalidPublic

Description

System Information
OSX 10.10.3
GTX580
GTX560Ti
Intel 4000

Blender Version
Broken: 2.75 208a917
Worked:

When motion blur is turned on and I hit render for a specific project that I've been working on the past week, Blender crashes. The terminal shows the error "Segmentation fault: 11"

I'm using armatures with bone envelopes to give text motion blur. Possibly this is causing the crashing?

Just tried it with the stable 2.74 (000dfx0) release from Blender.org and it still crashes. Also tried the latest build from builder.blender.org (63f62cd) and that crashes also.

If you need the project file, is there a way I can get it to you without publicly posting it here? It's client work...

I've attached all the information that I can, I'm going to frantically try to find a workaround for this problem now (probably while crying) as this is due tomorrow. If you need any specific information from me, please get in touch, would be good to squash this bug...

Exact steps for others to reproduce the error
Open the project that I've made and hit render... (see above about the project).

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please attach here the .blend file that is crashing, we cannot do anything if we cannot reproduce the issue first and foremost.

Yes, good point. Ok. Here you go. Packed everything (tried rendering the packed version to make sure it crashes too). It's the scene that's active when you open. If you animate, it'll render a couple of frames, then crash with a segmentation fault...

Thanks.

{F196991}

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.
Sergey Sharybin (sergey) lowered the priority of this task from Normal to Needs Information from User.Jun 30 2015, 11:08 PM

Can not see the bug here, it renders just fine. Several questions tho:

  • It is CPU or GPU render?
  • If it's GPU render does CPU render also crash?
  • Does it crash when rendering sill image?
  • Does rendering with locked UI or fullscreen render makes a difference ? (it could be well-known conflict between viewport and render threads)

Just to be clear. Is this a so called hackintosh machine ?

Our avx detection + hackintosh might cause this.

Incorrect nvidia driver installation might cause this

There are some bones (and consequently a few curves being manipulated from this) which is scaled from 0,0,0 to 1,1,1... We have had issues with scaling from 0,0,0 in the past with a gtx 580 in conjunction with deformation motion blur.

Disabling deformation motion blur, or scaling from 0.0001 will fix the crashes.

I could never produce a decent test case for this which was not under NDAs... and I cannot make this render fail either.....

Sorry about the light details originally, pushing up against a deadline, ended up rendering without motion blur for the first draft.

It crashes using both CPU and GPU, just checked again on the latest build from today (bbeb8c5).

Yes, it crashes when rendering a still image on both CPU and GPU

I've locked the UI and it still crashes. Making a viewport fullscreen (shift-space) and rendering fixes the bug on both CPU and GPU (for both animation and still image).

Yes, the machine that I created the project on and first noticed the bug is a Hackintosh (Mostly for Blender really, not a fan of Windows, need to use Adobe software so can't use Ubuntu but also need nVidia GPU rendering for Blender, which rules out most macs). Just to make sure that it wasn't down to it being a Hackintosh, I tried rendering on an iMac that we have in the office. It doesn't have a GPU, so couldn't test that, but it did crash with CPU rendering. I would just notch this down to being a bug related to the machine being a Hackintosh (if the iMac wasn't crashing too), but up until this scene, Blender has been rock solid on it. It's just finished rendering another scene on both GPUs for 2 days solid without a crash.

As far as nVidia drivers, CUDA etc, they're both on the latest version (but seeing as the crash is happening on both CPU and GPU I'm guessing this isn't too relevant now).

As far as scaling from 0, I just tried deleting the objects that are scaling from 0, but it still crashes.

So, it does seem to be something to do with a conflict between viewport and render threads, as Sergey suggested...

Just to be sure that you're all rendering the right scene (it should be the one that's open when the project is opened), I've stripped out all of the other scenes in this file:

{F199080}

If it's all all relevant, the GPUs aren't connected to any displays (used purely for rendering), leaving the intel graphics to drive a monitor through Display Port

What are the exact steps reproducing the crash with your file? Are you able to reproduce the crash on iMac with this exact file?

I've opened it and it renders animation without any crash (i didn't render full animation tho, because it'll take quite some time here).

Sometimes it takes a couple of frames to render before crashing, but it's basically as simple as hitting the render button.

Exact steps:

Open project

Go to first frame (if rendering still image).

Hit render (or animate).

With animation, I've found that rendering on the GPU tends to render about 6 frames before crashing. With CPU, it crashes straight after hitting animate.

I tested the exact same file on an iMac with CPU rendering and it crashed exactly the same way it's crashing on the Hackintosh.

Do you think this kind of crash could be caused by an addon? I'm just thinking, both the Hackintosh and the iMac share the same preferences (using symbolic links to a NAS drive), so both have the same addons enabled etc.

One very odd thing that I found which will hopefully help in figuring out what the problem is. I wanted to try to narrow down the problem by finding out if a particular object in the scene was causing the crash. I deleted half of the objects in the scene and it crashed. I re-opened the project and deleted the other half of the objects in the scene and it still crashed. I deleted all of the objects in the scene and it didn't crash...

I've also since tried rendering on a Windows machine and it works no problem, which makes me think that this is OS X specific...

I'm out of the office for the rest of this week and the following week, so if you have anything you'd like me to try it'll unfortunately have to wait (sorry about that).

I'm seeing a similar problem running Dual GPU's (GTX690), in GPU or CPU mode, with or without OSL. At first I thought it was high poly count on small objects, so I decimated them and started to render more frames before crashing. I then turned off Motion Blur and rendered 16 frames when I got:

CUDA error at cuCtxCreate: Error Unknown.

Won't continue to render at this point.

As far as the high poly count, that's related to a separate bug that I haven't had a chance to submit yet where if I have very simple planes (low poly) I get black artefacts appearing in the renders. Will submit that when I get a good example and have time.

Hi,

I got my scene to render. It had to do with the GPU fans. They weren't pulling enough heat away. There is an app (EVGA Precision X 16) that allows you to crank up the settings. I turned up the fans to 3000 rpm and rendered 150 frames over the course of 5 hours without any problems. Hopefully when I rendered the next scene I'll try motion blur. I have a feeling it should be fine.

I'm not sure if that's causing the problem on my end. I often have Blender rendering for days with both GPUs and the CPU without it crashing. The GTX580 will be between 90 - 98 degrees for the whole of this period, but it doesn't fall down. With this scene, the GPU doesn't get a chance to even warm up before crashing...

The test file should definitely be rendered with motion blur, as that's what's causing the crash on my end. No problem at all rendering without it.

Would it help if I made a screen recording of the crash? What other information should I provide?

Screen recording does not help. Only real helpful thing is to make it so other can reproduce the same crash as you're experiencing. So far with the given steps i can not reproduce the issue.

Thing is, if fullscreen render works, then it's almost 100% a threading conflict. However, not sure why locked interface still crashes for you. Just to be sure, by locked interface i mean this option: http://wiki.blender.org/uploads/3/3b/GSoC-DepsGraph-LockInterface_upd.png Is it what you've been using while testing?

Yes, that's the button I enabled to turn on locked interface.

I'm just rendering the scene without motion blur now, but wanted to submit the bug to help stabalise Blender and all that. I'm sure you have more important bugs to squash, this does seem to be quite a niche error and all. Unfortunately I can't give any more specific instructions to re-create the bug as it's as simple as hitting the animation button.

I'll try wiping the preferences for Blender on the Hackintosh and iMac and test again, it's the only common link between the two machines and the only reason I can think why I have 2 computers running OSX that crash with the scene while nobody else seems to be able to re-create it...

If it's still crashing after that, I'm happy for this bug to be closed as an "unsolved mystery" type thing...

Clearing the preferences has stopped it crashing. Going to investigate what setting/addon is causing the crash...

Ok. Finally got it, the addon 'Typewriter Text Effect' is causing the crash, can be downloaded here:

http://urchn.org/post/typewriter-blender-addon

Crashing is very variable, it could crash in the first frame of animation, or frame 30.

The question is, is this bug a fault of the addon, or is it doing something that Cycles isn't yet ready to do? I'm thinking that having deformation motion blur turned on along with an addon that animates the addition of additional mesh might be the bad combination that's causing the crash (but that's just a layman guessing).

I've done a bit more testing and narrowed down the problem further. The text that's being animated by the addon needs to have an armature modifier, set to envelope, with the envelope of the bone covering the entirety of the text.

Here's a simpler example where I've stripped out everything that's not related to the bug.

I'm also going to remove the previous two files as they're no longer needed.

Aaron Carlisle (Blendify) closed this task as Invalid.
Aaron Carlisle (Blendify) claimed this task.

We can not except bug reports that are caused by addons not in an official blender release. Please get with the vendor of the addon to report the bug

Um... You won't accept the bug report from me, but if I get the addon developer to submit the bug, you'll accept it?

Ah, sorry, I just re-read your response and understand now.

I'm sorry Aaron, but I disagree. The addon isn't at fault. The addon is doing what it's supposed to do perfectly well. It's Cycles which is crashing because it doesn't seem to be built to handle mesh being added with deformation motion blur turned on.

@stephen thomas (stephenthomas0), it is a known issue with conflict between render and viewport threads. Locked interface was meant to solve majority of common cases, but its still possible to fail the lock and crash.

Real solution is to implement copy-on-write approach which is planned to happen but it'll take some time still.

Thank you Sergey, really appreciate the response and all of the hard work that you guys do.

Sorry if I sounded a bit blunt back there Aaron. It just kind of felt that you'd read only my last post, saw that I was referring to an addon and decided to close this down with a stock answer of "we don't fix external addons". I hope you can see my position, where I spent a couple of hours yesterday wading through all of my preferences to find the problem, only to have someone seemingly shut it down without reading all of the details...

Thanks again guys, keep up the good work.

It's frustrating when things don't work in blender but that's half the fun... Tying to find work arounds for everything. A better work around is rendering from the command line which hardly ever crashes

Agree with you there Aaron, now I know about it, I can certainly work around it. Can't say things not working is solely within the realm of Blender though. The latest Premiere CC2015 feels like alpha software. Terribly buggy, almost feels like a waste of money...

Hmm... Sounds like windows 8 lol