Page MenuHome

Image Node
Closed, InvalidPublic

Description

System Information
Windows 7 Pro 64bits
16Gb RAM
GTX 960

Blender Version
Blender 2.75RC2 Hash: c85a58a

Short description of error

When I click open in a existing Image Node with a Multi EXR, to choose another image, it reset to Composite. So, I must remake all connections from this node. Simetimes, after change to Render layers, Blender closes.

Details

Type
Bug

Event Timeline

Antony Riakiotakis (psy-fi) triaged this task as Needs Information from User priority.

Can you attach a really simple blend file with the issue please? Thanks!

Can you provide two of the multilayers as well so I can test switching between them?

Antony, how can I send them? Each one has 110Mb.

Can you make small ones with the same inputs? I don't need the same exact files, just a small multilayer with the same input data that causes the issue.

Thanks!

I´ll make a small and low quality render

Hi Antony, did you see the issue? The most commom one is when I change the image. All connections are lost. Sometimes (rare moments), Blender crashes.

Antony Riakiotakis (psy-fi) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jun 30 2015, 2:39 PM

Since the files have different names than the ones in the file I had to create and connect a new image node the same way the old one was connected (to keep the old as reference for the connections). After that, changing between files did not lose the connections or crash for me.

We had some fixes for multi layer exr imports in master though, maybe that's the reason why?

Can you try a build from buildbot and see if issue is still there?

Even with same names and same connections, the node is reseting. I´ll try versions from buildbot and post here. Thanks.

Antony, I tried the 56ca7f3 and 6b00f4 and the both have the same issue.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

@Antony Riakiotakis (psy-fi), what are actually the steps of reproducing the issue? And can you reproduce it?

I can't reproduce it here.

Only "issue" I've seen is in original file where choosing different images disconnects the nodes indeed, but I can't get a crash and also there are no files packed with original file.

I would definitely recommend the reporter to make a file that causes the issue using the small images, make sure the paths are relative and zip all together and paste them here. Basically you should be able to take that zip on a different location in your drive, unzip it and get the crash by changing the images.

Another idea would be to pack all images into .blend file as well.

@Leandro Oliveira (leandrooliveira) we would really appreciate your help on making it clear steps of reproducing the issue. Things which are obvious to you are not obvious for us and vice versa.. Also, what exactly means "reset to Composite" ?

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

No news since one week, closing for now (we can always reopen if/when required info is provided).