Page MenuHome

Movie Clip Editor's Dopesheet and Grid views don't respect their corresponding grid color settings.
Closed, ArchivedPublic

Description

System Information
Linux 4.0.7-2-ARCH
GK104 [GeForce GTX 770]

Blender Version
Broken: eg. 2.74 + 2.75

Short description of error
Movie Clip Editor's Grid and Dopesheet views' grid theme colors can't be set anywhere. I would recommend to link those to their corresponding Dopesheet Editor and Graph Editor grid colors as they are already present.

Exact steps for others to reproduce the error
Screenshot of Movie Clip Editor grids

Details

Type
Bug

Event Timeline

Tom (t.ask) updated the task description. (Show Details)Jul 1 2015, 7:36 PM
Tom (t.ask) set Type to Bug.
Tom (t.ask) added a subscriber: Tom (t.ask).
Tom (t.ask) created this task.
Tom (t.ask) raised the priority of this task from to Needs Triage by Developer.
Julian Eisel (Severin) closed this task as Archived.
Julian Eisel (Severin) claimed this task.

Thanks for reporting, had a quick look into fixing, but we either had to be inconsistent by using theme colors from other editors (currently graph and dopesheet view both use clip editor theme colors and nothing from real graph/dopesheet editors), or we had to add extra theme option(s) for this.
We're really careful at adding new theme options as we already have much to much (several hundred approximately). We've gone a bit too far with the "everything themable" idea.

So I don't think any of both solutions would be good for now and besides from that, I wouldn't consider this a real issue or even a bug.

Closing as todo for now.

Because it interested me I just counted a bit: We have 756 color and 119 other theme options :S For now that should be enough :S

I see where you are coming from. The issue is, that those two grid colors seem to be the last missing non-controllable theme options I found. Sure, we can just say, no more theme additions, while from my point of view this would hit ourselves, because theming is not complete here.

While I think of it, the best way to solve this would be to add one Grid: option to the Movie Clip Editor/Theme Clip Editor settings and then use it for both missing grid views.

Besides, the present theme options number can be reduced significantly without loosing too much flexibility. But this shouldn't be the subject of this report.