Page MenuHome

"Set Stereo 3D" doesn't work properly
Closed, InvalidPublic

Description

As mentioned in T44301

System Information
Windows 7 Enterprise 64 Bit SP1 on a Intel Core i7-4800MQ, AMD Radeon HD 8790M / Intel HD Graphics 4600, Blender c6b042b

Short description of error
Changing the display mode does not change its settings that go with it when Window Draw Method is not set to Triple Buffer

Exact steps for others to reproduce the error

  • Set the Window Draw Method to Overlap or Overlap flip in the User Preferences - System
  • Enable Views in the Render Layers tab
  • Click the Window menu and Set Stereo 3D
  • Change Display Mode
  • The corresponding settings below it don't change as they should

But when you set the Window Draw Type to Full or Triple Buffer the problem is gone. Somewhen I saw a hint at the top saying something that Quad buffer is not supported on my side. Probably the Views Setting shouldn't be available when ones graphics card doesn't support it properly or the Window Draw Type is set incorrectly.

As mentioned on Blender Nation by DALAI, Triple Buffer is needed by Multiview.

Details

Type
Bug

Event Timeline

Johannes Thomas Meyer (Samoth) raised the priority of this task from to Needs Triage by Developer.

Not 100% sure this is a bug, but will let you decide here, Dalai.

Bastien Montagne (mont29) triaged this task as Normal priority.Jul 3 2015, 1:11 PM
Dalai Felinto (dfelinto) closed this task as Invalid.Jul 3 2015, 4:33 PM

That's not a real bug, but let me reply it anyways:

Probably the Views Setting shouldn't be available when ones graphics card doesn't support it properly or the Window Draw Type is set incorrectly.

I see your point, but it's not that easy to do it. What I did was to update the manual to mention Triple Buffer:
https://www.blender.org/manual/render/workflows/multiview.html

(there is a note right on the begin)