Page MenuHome

Camera does not rotate in walk mode (Shift - F)
Closed, ResolvedPublic

Description

System Information
Win7 64bit, GTX 560

Blender Version
Broken: 2.75 c6b042b
Worked: 2.74

Short description of error
Sometimes when switching into the walk mode (Shift + F) in camera view the camera doesnot react to mouse movement. I found out that it is caused by fast mouse movement while pressing the Shift F combination.

Exact steps for others to reproduce the error
Open a new file, add a camera, switch to camera view.
Move your mouse quickly from left to right (or make quick circles with the cursor). Press the Shift F combo while moving your mouse. If you do it right the camera switches to the walk mode but does not rotate. The WSAD keys work as they should.
If the cursor is still during the shortcut everything works as expected.

Event Timeline

Marek Moravec (marek) updated the task description. (Show Details)
Marek Moravec (marek) raised the priority of this task from to Needs Triage by Developer.
Marek Moravec (marek) set Type to Bug.
Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.Jul 7 2015, 12:40 PM

Can confirm the issue.

@Julian Eisel (Severin), @Dalai Felinto (dfelinto), do you guys mind looking into the issue? :)

I can't reproduce this on OSX :/

Can you check if you can reproduce this for the Fly View Navigation as well? (change the default View Navigation mode in User Preferences > Input)

Can't reproduce on Linux either. @Sergey Sharybin (sergey) on which system did you check?

Same as mentioned in the report -- Windows 7 64bit.

@Dalai Felinto (dfelinto): I can't reproduce this in the Fly View - problem only in the Walk mode.

I have the same issue. Windows 7 64-bit.

I can. win32.
It does not reappear at all if I do not change it while moving a mouse.
However, it does not reappear surely.

Can confirm this bug (with and without mouse movement) in 2.75 and 2.75a.
WASD works fine.

Mac OS X 10.9.5 (Mavericks)