Page MenuHome

Z-Transparency at alpha 1, it makes artifacts.
Closed, ArchivedPublic

Description

It happened with a MakeHuman model, till I discover this.

The faces that the normal is pointing to the camera are in front of all the faces that have in front. With alpha at 1, it should not happen this.

  • Open the file
  • Enter in Game Engine
  • Look at the right ear.

I think it is important now, because if I want to change it GLSL Material alpha with D511, the Transparency has to be on and, as far I know, Z-Tranparency must be active. If this method is not the suggested to be used in BGE, "Mask" does not act as a mask (*) and "Raytrace" is not something to be used in BGE.

(*) Mask is doing something weird... with alpha at 0, the object is not visible. At a low value, sometimes it mask the object that has behind (showing the world color, acting as mask), sometimes it appears as transparent... but, now, I can't reproduce the mask result. Maybe, another bug report.

Details

Type
Bug

Event Timeline

Mario Mey (mariomey) raised the priority of this task from to Needs Triage by Developer.
Mario Mey (mariomey) updated the task description. (Show Details)
Mario Mey (mariomey) set Type to Bug.

@Mario Mey (mariomey) transparency mesh are rendered without depth test so it depend on the order of poly gone in the mesh.

@Porteries Tristan (panzergame), sorry, I don't understand... could you explain it more?

You say that it is rendered as expected? And which method should I use to modify transparency dinamically? Using Mask or Raytrace? In these cases... the name of that transparencies were wrong. It is not Nask and it is not Raytrace.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Jul 28 2015, 4:09 PM

For the proper transparency working in viewport you need to sort faces, so first you draw faces with highest Z depth and then drawing faces with lower Z depth. This is something what is not implemented yet and implementing it is a bit tricky without causing slowdown.

But will let BGE guys to handle the report from this point.

It seems tha viewport transparency has a better support of Backface Culling than BGE's one.

That's only for BGE.

@Sergey Sharybin (sergey): So it's a viewport bug and there's no reason to link it with BGE, no ?

It seems tha viewport transparency has a better support of Backface Culling than BGE's one.

An example please ?


Same blend with a little bit of transparency.
With backface culling on, you don't see the ear into viewport as in BGE.

@Porteries Tristan (panzergame), seems i got confused at some pointwith other report. If BGE gives proper transparency order with alpha sort enabled, then this isn't a bug, just some lack of features for the realtime viewport which isn't really a bug.

Gentlemen, I think here is a "bugs confusion".

Here is a screencapture of the bug I reported, been entered in BGE (with Opaque as Alpha Blend):

Here is another bug that @ronan ducluzeau (zeauro) presented in his report. It is in Viewport and it has a fix/workaround by enabling Backface Culling in Shading. Maybe a bug, maybe not.

Also, as @Porteries Tristan (panzergame) mention, I tried with Alpha Sort as Alpha Blend, in this report original blend file. This mode should fix this bug, but it is not complete. Look at the left eyebrow of Suzzane:

I hope this clarifies the bug that I reported and helps to go on finding a fix.
Thanks.

Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 2:19 AM
Aaron Carlisle (Blendify) claimed this task.

This task is being closed because the BGE has been removed in Blender 2.8.