Page MenuHome

FBX export results in wrong normals
Closed, ArchivedPublic

Description

I'm attaching a blend here. At the left of the screen you can see the original object and at the right, the exported-imported one.

Notice that the imported object has like faceted / triagulated faces when subsurf is on.

According to a friend of mine, this could be caused by the normal export options in fbx. He says that there should be an option for not exporting smooth normals.

I really don't know if that makes sense to you, but well, there is definitely an issue with normals here.

Details

Type
Bug

Event Timeline

Juan Pablo Bouza (jpbouza) created this task.
Juan Pablo Bouza (jpbouza) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) claimed this task.

You do can not export custom (loop) normals, just choose face or edge smooth groups instead?

Bastien Montagne (mont29) triaged this task as Normal priority.

It's the same result with the 3 options, normals only, edge or face, just try it in the file I attached.

This friend of mine, who is the user Oscurart, told me this happened to him when importing in 3DMax, and that he had to reset the normals with a modifier or something like that.

Bastien Montagne (mont29) lowered the priority of this task from Normal to Needs Information from User.Jul 12 2015, 12:17 PM

I really see absolutely no difference between left and right objects in this .blend? Can you please attach here a screen capture of what you see?

Will add an option to not *import* custom normals, anyway (makes much more sense than not exporting them imho, since in 99.99% cases you want your nice advanced shading to be exported!), but you can very easily remove that data layer too (Geometry Data panel of Mesh properties).

Ok alright!

Well if you see no difference it is actually a relief, cause it means that I alone have the problem, so my client won't see it :D

I guess you could close the bug then, now I should find out what's going on... I just tried and buildbot builds don't show this, so it's a problem with my compilation only!

Bastien Montagne (mont29) closed this task as Archived.Jul 12 2015, 6:55 PM

Uhu… very strange artifact indeed… I can confirm I do not see this here. :)

Closing for now then.