Page MenuHome

MSI installer does not create association with .blend files
Closed, ArchivedPublic

Description

System Information
Windows 7 x64

Blender Version
Broken: (2.75a)
Worked: (optional)

Short description of error
Hello. There is one unpleasant moment in the new installation package "Blender 2.75" from the Microsoft Installer. It does not create associations on a .blend files. It is sad that in version 2.75a is not taken into account. You can at that time, until you create a new installation package, get the registry keys that are assigned to the file associations.

Details

Type
Bug

Event Timeline

Alexander (IdeaGen) raised the priority of this task from to Needs Triage by Developer.
Alexander (IdeaGen) updated the task description. (Show Details)
Alexander (IdeaGen) set Type to Bug.
Bastien Montagne (mont29) renamed this task from MSI to MSI installer does not create association with .blend files.Jul 9 2015, 2:37 PM
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.

I cannot reproduce this. For me the installer executes 'blender -r' once the files are in place and before the installer exits.

You are using http://download.blender.org/release/Blender2.75/blender-2.75a-windows64.msi ?

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Jul 9 2015, 5:21 PM

I beg your pardon. It seems that because of the MSI file associations are assigned only after rebooting the PC. I'll check it more later. If it is, there is not enough notice of the system is rebooted.
But in any case, not displaying thumbnails of the project on icons .blend files.

There might be an issue where the installer creates a system level association and registraion of the thumbhandler.
But you having an older versions of blender also installed and that has a now invalid registration of the thumbnail handler that actually takes precedence.

I would run blender -r from the command line as your normal user

please report if that solves the issue for you.

Bastien Montagne (mont29) closed this task as Archived.Jul 21 2015, 7:48 AM

No news since one week, time to archive.