Page MenuHome

Disabling a sensor or actuator in the logic bricks breaks the python controller that calls it
Closed, InvalidPublic

Description

Version: 2.75a (Linux 64-bit)

How to reproduce:

  1. Open the attached .blend
  2. Inspect the script and play the moving spinning cube game.
  3. Start the game again with one or more sensors/actuators disabled (unchecked).
  4. Note that if the python script calls out a single deactivated logic brick, the rest of the script fails as though it didn't exist.

Expected Behaviour:

A disabled brick shouldn't do anything, but it should still exist for the python controller to call it without raising an error. It is useful for the user to selectively disable sensors and actuators by unchecking them, but if this breaks the whole script, it's not very useful at all.

Details

Type
Bug

Event Timeline

Sam Brubaker (rocketman) set Type to Bug.
Sam Brubaker (rocketman) created this task.
Sam Brubaker (rocketman) raised the priority of this task from to Needs Triage by Developer.
Jorge Bernal (lordloki) closed this task as Invalid.
Jorge Bernal (lordloki) claimed this task.

If you disable a logic brick, this one is not even created and therefore it can not be called from a script. This is a known limitation with deactivation logic system but it is not a bug. Sorry for the inconvenience.