Page MenuHome

Parenting object with constraint causes tansform
Closed, ArchivedPublic

Description

System Information
Ubuntu 14, 3xGTX580

Blender Version
2.75a

Short description of error
Parenting object with constraints in some cases causes tansform, even if constraint explicitly does not affect particular transform type (rotation/position) directly.

Exact steps for others to reproduce the error
In attached file parent object with a constraint to the empty.
Object changes position/rotation.

Details

Type
Bug

Event Timeline

Konstantins Visnevskis (kivig) raised the priority of this task from to Needs Triage by Developer.
Konstantins Visnevskis (kivig) updated the task description. (Show Details)
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jul 25 2015, 10:47 AM

Please try again, looks like you missed attaching your .blend file here.

Bastien Montagne (mont29) claimed this task.

Thanks for the file, but no bug here, setting the constraint is not enough, it does not set the inverse matrix. You have to click on 'Set Inverse' button to do so (and your child object will go back to its original location).

There is no set inverse button in the Copy rotation constraint.

Maybe I mis-described something. With the present setup in the file (no need to create new constraints), when parented, object changes position, though constraint is not even position related.

OK… See the issue, reopening for now, no time to investigate in coming days though.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

Not sure why blender copies constraints to workob.

As a workaround disable the constraints before parenting and enable them afterwards

Sergey Sharybin (sergey) closed this task as Archived.Jul 29 2016, 12:23 PM
Sergey Sharybin (sergey) claimed this task.

Constraints are quite weak in Blender and a subject for major re-code for 2.8. So would rather stop fixing non-a-regressions in this area and switch all energy to a new design.

Mentioned in the TODO list: https://wiki.blender.org/index.php/Dev:Source/Development/Todo/Animation#Constraints

Thanks for the report!