Page MenuHome

Using Min Max of the Mapping node and texture extrapolation
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Windows 7 Ultimate x64

Blender Version
Broken: 2.75
Worked: (optional)

Short description of error

When using the Min Max of the mapping node, if the texture has not alpha on boundaries, the extrapolation of the color is weird.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

There are 2 blend files, one with a texture where the top is alpha but not the bottom : http://www.pasteall.org/blend/37266 and the 2nd blend has the same texture but with a row of one pixel of alpha at the bottom and then, it works as expected : http://www.pasteall.org/blend/37267

Just go in Rendered mode to see differences.

Details

Type
Bug

Event Timeline

Emmanuel LORANT (asturias) created this task.
Emmanuel LORANT (asturias) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Resolved.
Sergey Sharybin (sergey) claimed this task.

This isn't a bug in the mapping node, it does exactly what you're asking to do -- it clamps coordinates to 0..1 range, making it behave like Extend texture mapping when texture is being extended across it's edge when texture coordinate is outside of 0..1 range. Only issue with that is that due to linear intepolation setting and texture being used as Repeat extension type it blends edge with the warped coordinate.

What you might do instead is to use Clip extension type of the image texture which was just added to Cycles (see rBf296259) and disable min/max setting in the mapping node.

So thanks for the report, it is now possible to achieve effect you want with the next upcoming nightly build.