Page MenuHome

map UV node produces image artifacts
Closed, ResolvedPublic

Description

System Information
Windows 7 Professional Service Pack 1
NVIDIA GeForce GTX 660

Blender Version
Broken: 2.75a c27589e

Short description of error
Using the map uv node in the compositor produces image artifacts. The uploaded images show one example image input, an example uv map and the result. The uv map is smooth and has no jumps, but the edges of the square in the output image look jagged. Also note that the output should not show the white line around the circle because there actually is a sudden change to black in the uv map. My guess is that there could be something wrong with the image coordinates used to access the uv map and/or the pixel weights used for filtering when applying the uv map.



Exact steps for others to reproduce the error
Attached is a simple blend file that renders a white square in low resolution and some linear texture coordinates that should not change the image when used as a uv map (though they change it a little). The composite node also adds a small offset to the uv map over time. So when stepping forward frame by frame the white square will slowly move; However, every two pixels it moves, it seems to jump back one pixel.

Event Timeline

Daniel Widmann (nion) set Type to Bug.
Daniel Widmann (nion) created this task.
Daniel Widmann (nion) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.

This actually seems quite the same as T42844, but needs some further investigation.

Daniel Widmann (nion) reopened this task as Open.EditedSep 2 2015, 5:00 PM

I took todays dailys build (Date: 2015-09-02 03:41 Hash: f6e0262) and tested it. I made some tests with one fixed uv coordinate for the whole image and some tests with linear, "undistorted" uv maps and got the results I would expect. With other UV Maps, however, there still seems to be something off. See the strange checker like pattern on this bush after applying a uv map to the image:

Edit: Note that the left side is only a zoomed in image of the right side and not the application of the uv map. The UV map has already been applied on the right side.

I have made a .blend file to reproduce this effect. There is also a text object with instructions included in the blend file:

This might also be caused by the EWA Filter itself rather than the MAP UV node.

Sergey Sharybin (sergey) closed this task as Resolved.Sep 2 2015, 5:51 PM
Sergey Sharybin (sergey) claimed this task.

Please don't report old reports with new issues, submit a new report instead.