Page MenuHome

Particle system of descendant of transformed proxy causes proxy to lose transformation, reverting to it's source's transformation
Closed, ArchivedPublic

Description

Given a proxy of an object with a transformation. Given a particle system attached to an object that is a descendant of said proxy. The root proxy is displaced as in the object "gun_2_src_arma_proxy" in tester_consumer. On emission of particle, the entire proxy hierarchy is displaced back to the source position on particle emmision.

It is irrelevant if the type of particle system (proxy,linked,etc). Any particle system attached to a descendant of a displaced proxy causes the displacement applied to proxy to no longer apply.

This is very annoying and renders the workflow I am attempting to create linkable objects an impossiblity without resorting to possibly:

  1. Proxying emitter in tester_consumer
  2. Applying constraint to following a positioning empty as opposed to relying on a parent-child hierarchy

I haven't tested said workaround.

Note: This is a critical bug that cannot wait for a comprehensive refactoring of the particle system as it makes the creation of duplicated objects as intended by the workflow delineated in these test files quite impossible.

Details

Type
Bug

Event Timeline

Diet Coke (dlots) added a project: BF Blender.
Diet Coke (dlots) set Type to Bug.
Diet Coke (dlots) created this task.
Diet Coke (dlots) raised the priority of this task from to Needs Triage by Developer.

The workaround is to create a child of constraint on a particle system. Regardless, I believe this should be maintained as a bug and fixed regardless of any possibility of a particle system rewrite.

Julian Eisel (Severin) triaged this task as Confirmed, Medium priority.

Yep, something weird going on here. @Lukas Toenne (lukastoenne), @Brecht Van Lommel (brecht), what do you think? Is this fixable without causing more trouble?

Steps to reproduce: Open tester_consumer.blend, play animation

If this is a bug and it's not fixed, then not because we don't want to or so. The issue with particles is that fixing one bug causes multiple other ones. Particles are broken and *need* a rewrite.

Known bug, particles emission can only handle direct parent object relations for emission interpolation via ugly hack.

Julian Eisel (Severin) closed this task as Archived.Aug 14 2015, 10:07 PM
Julian Eisel (Severin) claimed this task.

Closing as limitation then. @Diet Coke (dlots), we're all not happy about the current situation, but we can't do much without a particle rewrite.