Page MenuHome

Crash and shutdown on accessing System tab in User Preferences
Closed, ArchivedPublic

Description

System Information
Windows 7 Pro, AMD Radeon HD 6490M, HP Pavilion DV7 laptop with Intel i7

Blender Version
Broken: 2.75, 2.75a
Worked: 2.74

Short description of error
Blender shuts down suddenly when clicking on the System tab in user preferences, also when selecting "System Info" in the Help menu (which is why I've included the system-info file generated from a 2.74 version).

Exact steps for others to reproduce the error
Open Blender > Go into User Preferences > Click on System tab (crashes)
Open Blender > select Help > System Info from the menu (crashes)

Details

Type
Bug

Event Timeline

Dave S-B (davesb) raised the priority of this task from to Needs Triage by Developer.
Dave S-B (davesb) updated the task description. (Show Details)
Dave S-B (davesb) added a project: BF Blender.
Dave S-B (davesb) set Type to Bug.
Julian Eisel (Severin) closed this task as Resolved.Aug 7 2015, 2:51 PM
Julian Eisel (Severin) claimed this task.

This was fixed already, you can try again using latest builds form buildbot.

Closing this for now, we can reopen if the bug isn't fixed. Thanks for the report.

Dave S-B (davesb) reopened this task as Open.Aug 11 2015, 3:34 PM

This is still happening in version 2.75.4 (from buildbot blender-2.75-c150645-win64.zip). Another place it crashes is when selecting Cycles as the renderer.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Aug 12 2015, 4:21 PM

Please:

  • Ensure both your OS and drivers are fully up-to-date.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak OGL settings in UserPreferences, System tab.
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Attach here the report generated by Help -> System Info.
  • Launch Blender from the command line and attach here any error printed out in the console.
  • Try to place this dll next to your blender.exe (software OGL, will be slow, but will show whether this is a driver issue or not).

This sounds like the GPU device querying bug, though, @Sergey Sharybin (sergey)?

--factory-startup : same issues happen
I can't get into the Settings tab in UserPreferences, so not able to change anything there.
GPU driver settings had no effect.
Help -> System Info just crashes Blender.
Command line : only error was "Error: EXCEPTION_ACCESS_VIOLATION".
Software OGL : same issue

Sorry this isn't more helpful :(

You still did not answered about GPU drivers, what’s exact version you are using (i.e. are they fully up to date)? Some drivers used to segfault when querying about their capacities (which is what happens when showing 'system' tab or running system info), iirc…

Sorry, I have the latest versions that are available. I've been looking into it though, and there's something more important (probably) - the laptop has dual switchable graphics (I never even new this!). It uses the on-board graphics, which is Intel HD graphics (hardware ID PCI\VEN_8086&DEV_0116&SUBSYS_1659103C&REV_09), for menial tasks and somehow switches to the AMD card for more demanding applications (hardware ID of the AMD card is PCI\VEN_1002&DEV_6760&SUBSYS_1659103C&REV_00). Blender version 2.74 is reporting the card in use as the Intel one. I'm attaching the system-info from that just in case it's any use.

Assigning to Sergey since iirc he has some testing tools for those cases… @Antony Riakiotakis (psy-fi) you may also have some insights here?

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Aug 21 2015, 5:46 PM

Does this happen with latest builds from builder.blender.org?

it's also a bit confusing, is it a laptop with both discrete and integrated video cards?

I've just downloaded and tried the Blender-2.75.0-git.4f61de6-AMD64 build - same thing happens.

Yes, that's right - it's a laptop with on-board (Intel) graphics and discrete AMD Radeon too, although the info from Blender 2.74 (which works ok) only mentions the Intel graphics. Here's a link to the product support page for the laptop if you want the gory details - http://support.hp.com/us-en/drivers/selfservice/HP-Pavilion-dv7-6b00-Entertainment-Notebook-PC-series/5145684/model/5177030#Z7_3054ICK0KGTE30AQO5O3KA30R1.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.Aug 25 2015, 3:44 PM

Think latest Catalyst still supports your GPU, please try upgrading it because it smells like graphics card driver issue.

I've just installed the latest AMD drivers using their auto-detect installer and now my computer's lost all accelerated graphics completely. So nothing can use OpenGL at all, including Blender. I'm going to have to get back to you after sorting it out..... :-( Feel free to close the issue or put it as very low priority - it smells like driver/card issues to me too now.

This was happening to me too, on a laptop running Windows 7 Professional. Many laptops (this particular one is a Dell E6530) have two graphics chips: the built-in Intel hardware is used for driving the main laptop display when low power consumption is required. The "real" chip (NVS5200M on this laptop) is used when multiple displays are connected, and when plugged in.

I had been running 2.71 with no problems. I upgraded to 2.76 and got the instant crash when switching to the User Preferences->System tab, or choosing the Cycles renderer. After thrashing around a bit, I tried shutting down Blender, disconnecting the external display, and restarting Blender. The crash no longer happened. Then I shut down Blender, reconnected the external display, and restarted Blender. The crash did not reappear. Now that I have access to the System tab, I have been able to select the Compute Device, and I can pick CUDA (and see the correct graphics card listed), and still no crash. Rendering with Cycles works fine. It seems like 2.76 is getting initially confused about the graphics card when multiple drivers/screens are present, and tries something illegal. Once it has been started in a simpler environment, theproblem goes away on subsequent restarts. I have not tested this across a hard reboot yet, but at least the workaround seems simple, even if the problem recurs.

Please test latest builds from builder.blender.org. There were some fixes in related areas.

The crash reappeared after I installed the latest Dell updates today, which included something new for the video subsystem. The nVidia GeForce Experience software reported the driver as being up to date (and the same version = 353.82 on an NVS5200M ) both before and after the Dell update, so I'm not sure what Dell added. With 2.76 release, the trick of unplugging the external monitor stopped working; I could not find a way to avoid the crash.
I downloaded the Dec 6 build for Win 64 from builder.blender.com. With that build installed, the workaround works again, i.e. if I shut down Blender, unplug the external monitor, then start Blender and switch to Cycles the crash does not happen. If I then plug in the monitor, I can move Blender to the external monitor without problems. I can stop and start Blender as desired and the problem does not reappear. However, if I reboot the laptop the problem reappears, and I have to start Blender once with the external monitor unplugged. If there are any experiments you would like me to run, let me know.

This problem seems to have been corrected by 2.76b release.

I'm having this same issue in 2018 (Blender crashes when selecting Cycles or selecting the System tab under user prefs). Does anyone know if there was a fix for this other than disabling screens? I have a two monitor setup on a desktop PC and I don't really want to be disabling a monitor every time I use Blender.
All my drivers are up to date and I'm using Blender 2.79.