Page MenuHome

Error: EXCEPTION_ACCESS_VIOLATION opening Blender on external monitor
Closed, ResolvedPublic

Description

System Information
Operating System: Windows Embedded 8.1 Industry Pro 64-bit (6.3, Build 9600) (9600.winblue_ltsb.150715-0840)
Processor: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz (12 CPUs), ~3.3GHz
Memory: 32768MB RAM
Card name: AMD Radeon (TM) R9 Fury Series
Card name: AMD FirePro W8100 (FireGL V)

Blender Version
Broken: 2.75a

Short description of error
Program crashes when accessing user preferences after setting preset to Maya and saving, restarting, then accessing trying to access user preferences.

Exact steps for others to reproduce the error
Ran command prompt on windows went to C:\Program Files\Blender Foundation\Blender and executed blender.exe. Clicked input and set preset to Maya. Click save preferences, save startup file, then restart blender. When blender opens I receive this when trying to access user preferences.

"C:\Program Files\Blender Foundation\Blender>blender.exe
Read new prefs: C:\Users\Delo\AppData\Roaming\Blender Foundation\Blender\2.75\co
nfig\userpref.blend
Win32 Error# (0): The operation completed successfully.
found bundled python: C:\Program Files\Blender Foundation\Blender\2.75\python
Error: EXCEPTION_ACCESS_VIOLATION"

Details

Type
Bug

Event Timeline

Delo Lat (edisto) raised the priority of this task from to Needs Triage by Developer.
Delo Lat (edisto) updated the task description. (Show Details)
Delo Lat (edisto) added a project: BF Blender.
Delo Lat (edisto) set Type to Bug.
Aaron Carlisle (Blendify) lowered the priority of this task from Needs Triage by Developer to Normal.Aug 14 2015, 12:09 AM
Delo Lat (edisto) added a comment.EditedAug 14 2015, 10:57 AM

So I recently was talking to the good folk in IRC. I believe the problem is possibly fixated in my dual monitor setup. I noticed in my primary monitor when blender was stationed did not crash. However, when I switched blender to my secondary monitor and saved startup is when it began crashing. Accessing user preferences pops up on my primary monitor. So we ran a few test of Duplicating window across monitors, and play render animation which popped up on my primary monitor but did not crash at all.

This seems something to do with OpenGL rather than with keyboard presets or so. This means @Antony Riakiotakis (psy-fi) is the person to be asked here.

I will need a system to reproduce this on though. There's little I can do without it. I tried the steps on my laptop but I don't have a two-screen setup so it always works.

You can not add your desktop monitor to your laptop?

I have a really old CRT, I'll try to see if I can reproduce it here.

Sergey Sharybin (sergey) renamed this task from Error: EXCEPTION_ACCESS_VIOLATION after changing input preset to Maya saving, restarting, and accessing user prefs. to Error: EXCEPTION_ACCESS_VIOLATION opening Blender on external monitor.Sep 4 2015, 10:22 AM

Can't reproduce the issue n my laptop using both integrated Intel and discreete NVidia cards. Thins is something GPU-related, so moving to our openGL tracker.

Meanwhile, did you test if earlier releases of blender works fine to you?

Please download the software OpenGL dll from ftp://ftp.blender.org/sergey/softwaregl/ and see if that hides the problem.
While that is not a real fix it could give us valuable info.

I have nasty feeling about AMD opengl driver in combination with our windows opengl context handling code.

Delo Lat (edisto) added a comment.EditedSep 22 2015, 12:19 PM

Please download the software OpenGL dll from ftp://ftp.blender.org/sergey/softwaregl/ and see if that hides the problem.
While that is not a real fix it could give us valuable info.
I have nasty feeling about AMD opengl driver in combination with our windows opengl context handling code.

So I downloaded the win64 version of opengl32.dll and placed it in my 2.76rc1 folder. And I lagged bad. I couldn't even close my window after fooling around for a bit.

I currently upgraded to 2.76rc1 which I notice had massive improvements in speed when sculpting and moving high poly objects. I notice the same issue however when I dock my blender window on the right monitor and save startup file and reopen. When I access my user preferences from the file menu blender constantly crashes with the same error.

Delo Lat (edisto) closed this task as Resolved.Nov 17 2015, 10:31 AM
Delo Lat (edisto) claimed this task.

Am using 2.76b and problem is fixed. When I save user preferences on my second monitor then exit and reopen I no longer crash with violation error. Instead the user preferences window pops up on my second monitor.

In addition I also upgraded to windows 10 so am not sure if that plays a role.