Page MenuHome

Textured Objects scaled to 0 cause black artefacts with Static BVH
Closed, ResolvedPublic

Description

System Information
Windows 7 64 Bit / Various NVidia Cards with current drivers

Blender Version
Broken: 2.75a / 2.75 / 2.74
Worked: 2.73a

Description
I have an animation I did with Blender 2.73a a few months ago. This animation uses textured plane objects I simply scale down to 0 to let them disappear.

I'm currently reusing this animation and when I try to preview/render it in Blender 2.75a with Cycles GPU rendering and Static BVH, there are strange black fields, but only if an object is scaled to 0. If I use for example 0.0001, everything looks fine. I can switch to CPU rendering and everything looks fine, too. Blender 2.74 shows the same behaviour but it works in 2.73a.

Looks like a bug to me and took me some time to figure out :-).

Cheers

Thorsten

Exact steps for others to reproduce the error
I added a Blend file that shows the problem. Open it, switch to Viewpoint Shading "Rendered" and go to frame 10, where the object showing the Blender logo is scaled to 0. A black field should appear.



Event Timeline

Thorsten Schlüter (thoro) updated the task description. (Show Details)
Thorsten Schlüter (thoro) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) renamed this task from Textured Objects scaled to 0 cause black artefacts with Static BVH to Textured Objects scaled to 0 cause black artefacts with Static BVH (NVidia GPU rendering).
Bastien Montagne (mont29) renamed this task from Textured Objects scaled to 0 cause black artefacts with Static BVH (NVidia GPU rendering) to Textured Objects scaled to 0 cause black artefacts with Static BVH.Aug 13 2015, 12:52 PM
Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Actually, not related to GPU rendering, can reproduce the issue with CPU rendering as well here…